FP3 - Unknown sources check - how to re-enable it

Dear all, I’ve started to use my new FP3, installing all the stuff I had in my previous FP2. Among the apps, I had to install also a couple of corporate apps, available in an internal appstore, so I had to enable the “Install from unknown sources” setting. Everything went fine, and now I want to re-enable the block against installation from unknown sources, but… I can’t find it anymore! It isn’t in “Security” settings, it isn’t in “Apps & Notifications”. I deeply browsed FP3 settings, but I couldn’t find it. I also enabled Developer setting, tapping on build number, but the install from unknown sources, seems vanished.
Did anyone ever face this apparent issue?


Don’t have an FP3, but on other devices it’s:
Settings > Apps & notifications > Advanced > Special app access > Install unknown apps > [name of app for which you want to toggle permission]


When I want to install an app in F-Droid.
Go to Settings
go to Apps & notifications
Go to F-Droid
Go to Advanced
Scroll down to Install unknown apps

I can confirm that it’s the same for FP3.


Thank you for your answers, but there is something that I can’t still understand: in my old FP2 (Android 7) there was a specific setting related to enable or disable app installation from unknown sources. Now, If I go to “Settings > Apps & notifications > Advanced > Special app access > Install unknown apps”, I can see the list of apps installed from PlayStore, but I can’t see the two corporate apps installed from the .apk package. They are of course present in the list Settings > Apps & notifications > Shows all apps.
Is it changed something in Android 9 in managing this security aspect?

There is something you don’t understand. What you see is the list of apps that are allowed to install those corporate, i.e. unknown apps. In my case, only the file manager I use to install apk’s, and F-Droid have that permission.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.