FP3+ Touch screen goes haywire when charging via mains, eventually stops charging and screen stops working

Hi folks

So I recently had my FP3+ repaired as it is still under warranty but it has returned without the original problem being fixed, I’d happily fix it myself even though it’s under warranty, but I don’t know how. Please help!

When I plug the phone in to charge via mains, the screen goes haywire and registers all sorts of touches that aren’t there, and it’s impossible to use whilst charging. I’ve tried different chargers and cables, it’s deffo the phone. When plugged into a computer the screen works normally, but the phone will only charge slowly, sometimes so slowly that it actually loses battery %.

Last time the problem got worse and worse until eventually it stopped charging all together, and then the touch screen also stopped working. So the phone became completely useless.

I contacted Fairphone support and they repaired it free of charge as it is still in warranty. When it came back it seemed to be working again, the touch screen works, it charges, but suddenly when I tried using the phone when plugged in the problem started again. I’m now worried it will get worse again, as the original problem doesn’t seem to have been fixed at all.

Fairphone support take a long time to reply to messages (this has been ongoing since April) so I’m hoping someone can just tell me what the actual issue is so I can either fix it myself or tell support exactly what the issue is so it can be fixed properly. I love my Fairphone and would hate to have to ditch.

Thanks folks

Welcome to the community forum.

Most likely this has already featured in your exchanges with Fairphone Support – have you tried other cables and chargers on your FP3+?


Yep as mentioned in the post I’ve tried multiple chargers and cables and it’s all the same, the cable it started with is the official Fairphone cable bought from the online store.

1 Like

Oops, sorry, missed that :blush:

Hi Your location and mains may be an issue. There may be too much static and the phoen its not earthed.

In the UK with a three pined plug the metal parts of a phone etc. are earthed. Where there are only two pins the mains network has to be aligned between products and even appartments if there is not overall grounding.

By aligined I mean internal wiring would have a common senss that either the negative or positive is grounded. Different equipment can chose either to earth the pos or neg which is fine for non sensitive devices like old fashion light bulbs but can cause problems with sensitive devices.

Someone may well disagree with my ‘old’ fashion ideas of mains. Note when using the computer you are probably grounding via the metalic chassis if it has one etc.

Hey thanks for replying!

Interesting theory! I hadn’t thought of this before. But I am based in the UK so should be fine? I think this also wouldn’t explain why it will only charge slowly via a computer and eventually not at all? I’ve never had problems with mains chargers doing this to other devices such as ipads, laptops or desktop computers, and every other phone in the house seems fine too. I really do think it’s a hardware issue with the phone. Come to think of it I’ve also used different chargers and cables at work on the mains there and had the same issue.

OK nice to know you’re in the UK so earthing may not be the problem, but I would still suspect it. What charger do you have, some have dead earth pins.

Where in the UK South West by any chance?

The phone has to communicate with the source else it will drop to the lowest option in it’s protocol. if you use a USB A socket of a computer with a blue insert (USB 3) that is 900mA if it is a black insert (USB 2) it is 500mA.

So you may expect 4 to 5 hours with the blue and 6 hours or more with the black (USB 2)

The FP3 uses a propreitory Qualcomm QC3 charging routine, which other devices, unless Android using Qualcomm chips, won’t react the same.

This link may help explain some of the charging issues

I’m in the North West.

Problem started using a Fairphone USB cable and an iPhone plug, but i’ve tried various plugs and various cables including an ipad cable, a playstation 5 cable, basically any cable I could find that has USB C, various plugs, mostly apple but some unbranded, i’ve got dozens and they all do the same. At work I plugged the USB cable directly into a USB extension lead. So all types of cables from all different brands with different power sources. I don’t really know much about this stuff so I’m not 100% sure what you mean by USB A or USB 3, but for 18 months the phone worked perfectly with all of these, as I would regularly charge it both at work and at home using a variety of power sources, whichever was convenient.

I’m really sorry but I’ve tried reading that link and I have no idea what any of it means. I just want my phone to work :frowning: if I can’t charge it using the official Fairphone charger plugged into the mains then surely the product is faulty? Do you have any advice on exactly which cables/plugs I should be using to charge it to prevent the problems described in the link?

Thanks again for replying and I’m sorry I don’t understand all of this!

Yes that wasn’t going to work well as the phone and the chargers negotiate at what voltage/power for the charger to apply and as Apple and Qualcomm use different languages it may not work well but may charge at a low rate.

The USB 2 or 3 defines the power at 5V that can be drawn via the USB A socket in a computer. Look inside the USB A socket it will be either black (version 2) or blue (version 3) Either way will not supply what Fairphone/Qualcomm define as Quick charging yet like above could charge at a slow rate.

Howvere you say you have both a cable and charger supplied by Fairphone and none of the other issues really matter if you use those as a pair.
I the Fairphone charger and able don’t work then as you say it seems the phone maybe an issue. Can you use the Fairphone charger and cable to charge another Android phone ? or anything.

If it’s down to the phone it could be the USB port, it could be dirty with dampnes or dust.

Another thing is to dismantle the phone to check a few things. Just the act of dismantling and reassembling may fix the problem as the Faiphone being modular can suffer form poor conatcs between the modules.

Dismantling will enable to ensure the contacts look clean and you can also check for damp ingress vis two indicators.

If the indicators are white and the phone is less than two years old you can contact Fairphine support for a query under warranty.

This post shows the white indicators the main one can be seen once the screen has been removed


For disassembly see the Fairphone tutorial on removing the screen

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.