FP3+ stuck on spinning blue dots, please help :)

Hello everyone,

Basically my FP3+ gets stuck on the spinning blue dots screen forever.
The only way to turn off the phone is to remove the battery.
And when I insert it again and power on the phone, it gets stuck again with the spinning blue dots (even after a long period without the battery).
I tried using a brand new sim card and it doesn’t work, whatever slot I insert it into.
Also I can’t access the safe mode.

It happened about 2 weeks ago and has been like this since.
I haven’t done anything special before it happened (no installation of apps, etc…).
The charging LED works fine.
The screen itself seems fine because the “fairphone” display appears before going to the spinning blue dots display.

I can access the recovery mode.
I guess I will have to go for a factory reset but since I haven’t done any backup recently, I am a bit reluctant and would prefer another way to fix my problem.
Is there a way to do a backup using a cable through one of the menus in the recovery mode ?
Or, even better, a way to fix it w/o going through factory reset ?

Thanks a lot !
PS: My computer is a macbook pro

To those more in the know: Does this work on the FP3 as well?

1 Like

Not sure if it will help but have you tried starting in Safe Mode, it may at least confirm it is in the Firmware etc.

1 Like

Yes I tried and it did not work :frowning_face:

1 Like

With an unlocked bootloader … even easier, you just fastboot boot the TWRP image in fastboot mode.
With a locked bootloader … no chance.


Keeping the power button pressed for about 15 seconds should force a reboot.

Is your bootloader locked or unlocked?
If you don’t know, then it’s probably locked, but you can make sure by booting into fastboot mode (keep Vol - pressed while starting or rebooting the phone), the state is listed there as “Device state”.


In any case, if it’s unlocked, the phone should show a message saying so, every time it’s turned on. I don’t think there’s a way of preventing it on the FP3?


the bootloader it is locked :frowning:

1 Like

So no way to get my data ? :frowning:
Thanks all

No easy or cheap way :frowning:

1 Like

I ended up doing a factory reset…
Thanks all for the help.


Hi Axel,

I have the same issue.
How did you manage to perform a factory reset ?
On my side, when I go on recovery mode I get a “No command” message with an Android logo on his back.

Update : I managed to perform factory reset by pushing the power button and the Volume up button together and it solved the problem.

1 Like

here is the protocol (with link below):

  1. Press and hold together the Power button and the Volume Down button for about 10 seconds.

  2. Pay attention to the screen of your Fairphone 3(+). Once the writing Fast boot mode appears briefly, release the buttons.

  3. A text appears with Start as the title, in green.

  4. Use the Volume buttons to change to Recovery mode, in red.

  5. Press briefly the Power button to select.
    Wait for 5 to 10 seconds. Once the phone reaches the system recovery, you’ll see an Android robot lying on its back. You’ll also see the message No command.

  6. Now, press and hold the Power button, then press and release the Volume Up button. A new menu with blue, yellow, and white text will appear.

  7. Use the Volume Up or Volume Down buttons to select Wipe data/factory reset.

  8. Select Yes – delete all user data to confirm that you want to delete your personal information.

  9. Again, confirm tapping the Power button.
    Once the action is complete, all the way at the bottom left, in white small text, the message Data wipe complete will briefly appear. The Recovery system menu will appear once again.

  10. Use the Volume Up or Volume Down buttons to select Reboot system now.

  11. One last time, confirm tapping the Power button and wait for your device to restart.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.