FP3 stuck in splash screen with iodé

Goody morning,

I have an FP3 with valuable data here in front of me which is stuck at the splash screen of iodé (because of the personal data I don’t want to factory-reset it). When it stays there for some time it even gets warm, but it does not boot up. It was just restarted at some time and without any sign of a problem before it got stuck there.

What I have tried so far:

  • remove SIM-cards and µSD-Card → doesn’t help
  • insert a different battery
  • start in safe mode (after FP-writing disappears vol- → doesn’t work (stays stuck there, too)
  • boot into fastboot → works, but doesn’t help: tried to switch slots, but neither of them boots beyond splash screen. what else could I do there?
  • boot into recovery → works, but I can’t push/pull anything as I always get

error: device unauthorized.
This adb server’s $ADB_VENDOR_KEYS is not set
Try ‘adb kill-server’ if that seems wrong.
Otherwise check for a confirmation dialog on your device.

(killing adb server of course didn’t help). I guess debug mode isn’t enabled?

  • sideload iode-3.4-20221215-FP3.zip → works, but doesn’t start either. (I hope this step didn’t delete the data?) → still stuck

I have run out of ideas and my friends is becoming really sad :frowning:

What else could I do?

Depending on how valuable the data is you might try to get advice from professional data rescue services.

Was this the build which was installed before? If not, I’d rather try the build which was installed before.

The bootloader is locked, I assume?

There’s an iodé community, too … https://community.iode.tech

2 Likes

Thanks for your reply!

Well, it’s family-pictures…

That I can’t tell for sure, it was just the build which I pulled from the website, but I am pretty confident that it was 3.4.

No, it is unlocked. Can it even be re-locked on FP3? I didn’t know of that, quite interesting!

I know, but as I didn’t know whether it is an FP-issue or a iodé-issue, I firtstly tried posting in the more active community :slight_smile:
But maybe I’ll try my luck over there, thanks!

I wish you a happy new year!

For reference, if someone wants to follow or encounters the same problem, I leave the link to the iodé-forum:
https://community.iode.tech/t/fp3-stuck-in-splash-screen/1064

In this case you could try to simply boot TWRP with fastboot and see whether it asks for the decryption password of the user data, which would be the unlock password/PIN for the Android lock screen (I don’t know whether the bottom of this page still helps with unlock patterns, or if TWRP is able to prompt a pattern UI).

If TWRP asks for the password (should be the case up to Android 11 *), and if the correct password can be provided, TWRP should be able to decrypt the data partition, and you should be able to copy the whole Internal Storage to a computer via USB.

(* At least in /e/OS based on Android 12 the encryption changed to a type TWRP can’t decrypt currently.)

3 Likes

I was happy when you braught up another possibility, but unfortunately it never asks for a password. Terminal just says

sudo fastboot boot Downloads/twrp-3.6.2_9-0-FP3.img
Sending ‘boot.img’ (30924 KB) OKAY [ 1.403s]
Booting OKAY [ 13.634s]
Finished. Total time: 15.072s

The phone boots up till the screen with the FP-logo and sits there doing nothing. Tried with TWRP 3.7 and 3.6.

I think I’ll leave it switched off till tomorrow and try again, I don’t want to ruin my last day of the year :wink:

That’s odd.
Perhaps switch the slot and try again.

1 Like

Happy New Year!
Unfortunately, this didn’t do the trick either.

The place of the phone which is becoming warm is (when I have the opened phone lying in front of me) seems to be the place left of the battery above the µSD-slot. Which part is this, do you know? Maybe it is not a software-problem but a hardware one?:frowning:

1 Like

Thus, it is probably either the SoC or the RAM. Not so nice.

Last message: the FP is running again. but not with iodé and I could not save the data.
I finally flashed the original A11 and because it still did not boot (unsurprisingly) did a factory reset :frowning:
Obviously not a hardware but a software problem.

1 Like