FP3 sometimes double/tripple letters or numbers

Hi folks,

I’ve a new FP3 phone since 2 months.

Everything was fine and the device is working properly, but one things is really strange.

I am not sure under which circumstances the problem appears. It seems, that it happens without a special action. Sometimes it is not for a week and than it comes again multiple times in a week.

The problem is that letters and numbers (even pin entry on reboot) the numbers will at least doubled or trippled. So when i hit on 5 it comes 55 or 555. The sames happens with letters. I tried several reboots, but even on pin screen the problem appears.

The problem stops so fast as it came. I don’t now why it starts at all.

I checked the forum for a similiar issue, but just found ghost lettering issue with FP2. Which is different than my problem.

My FP3 is on the last software level. Security updates are of stand 05. April 2020.

Has anybody within the community the same issue?


Hello Solarsurfer,

That sounds too familiair: I am experiencing the same problem. For time to time all the keys that I press double or tripple: a becomes aa or aaa etc. The only way to work the phone is to touch the keys very very softly and briefly and sometimes that even doesn’t work. The issue comes and goes and I haven’t found a pattern yet.

So, unfortunately I cannot help you, I can only sympathise with you.



Something like this happens when it is connected to a charger. It reacts as usual when the charger is disconnected / switched off. Haven’t noticed it in other situations really.


thanks for your feedback.

@mmxmmx, you are right. I can reproduce the issue, when the device is connected to power supply! That is kind of strange. Any suggestion why or a possible solution? I mean will it end in strange things and self destruction or something similiar? :wink:

I remember, that I had the impression the issue started, as I addes the display foil. But this can’t be the cause, otherwise it would do that also in unattached power state.

I am aslo experiencing this issue. i tried factory reset but this did not solve the problem. The only solution i have found is to wait until it gets better but this is not really satisfactory.
Does someone managed to solve it?
Many thanks!

There are two physical options as the screen react to electricity in your finger via electromagnetic charge so the screen or finger could be damp or you may have static electricity on the screen or your body.

If the problem is consistent to rule out static you could earth your hand and/or the screen.

You can also test the screen via

  • Opening the phone dial pad
  • Entering *#*#66#*#* to show testing menu
1 Like

Thanks for this code. Thats quite interesting.

The problem went away with one of the last updates. Or at least I didnt recognize it anymore. :wink:

It was indeed, only with Power supply attached. When it ia unplugged, its working as expected.

1 Like

Indeed, the latest update contains a fix regarding this issue:

Adjusted the sensitivity of the touchscreen component, to avoid potential “ghost touches” under certain circumstances.

@Oriel Have you checked if you’ve already installed the latest update (3.A.0077-20201221)?

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.