English

FP3 random reboot loop

I’ve had my fairphone 3 since December 2019, and this is the second time it has gotten caught in a reboot loop - first time was in Feb.
Not sure what set it off in Feb, but I was using WhatsApp at the time and the phone had 52% battery - the phone switched itself off for no apparent reason, and then proceeded to get stuck in a rebooting loop that lasted about 2 days.
This time I was using my phone when it started, the battery was low so I initially thought that was the problem, but when I started charging it, it started the rebooting loop again. It’s been 3 days now.

The boot loop is only a few seconds long, so there isn’t much I can do here. I haven’t managed to boot it in Safe mode, and can’t seem to access the factory reset.
I’ve tried power & volume+ which brings up the Android No Command error.
I’ve tried power & volume- which brings up the Fast Boot mode screen, but when I try to interact with it in some way, like pressing buttons or the touchscreen, it doesn’t respond, and after a short while, it starts rebooting again.

The boot loop continues going until I remove the battery. It will literally carry on for hours if I let it. It also usually starts as soon as I put the batter back in. If it doesn’t start as soon as the battery is in, it starts either as soon as I press the power button, or it turns on fully (I’m able to put my password in, receive a backlog of notifications, even read some of them) before boot looping again.
It makes no difference whether it’s plugged in or not.

My software was up to date, but I don’t think the random rebooting is the result of recently updated or downloaded software.
I have removed the SD card (this allowed the phone to switch on for about a minute before random reboot loop started again).
I removed the SIM card, which made no difference. I tried a different, brand new SIM card, which made no difference.

Many people experiencing similar problems on the forum suggested it could be a battery problem.
Plugging the phone in to charge tends to start the boot loop, but I did manage to fully charge it (til the light was green) overnight without the boot loop starting.

When this happened in Feb, it just started working again after a couple days. But I don’t know if it will start working again this time, and I’m really losing trust in my fairphone.

I don’t know if it’s connected to the rebooting, but I’ve also experienced some intermittent issues with the receiver and speaker.
It hasn’t happened in a while, but sometimes for a few days, with no apparent trigger, I can’t hear anything when receiving phone calls or playing sound on the speaker, so need to use my earphones. It starts working again randomly after a few days. This has happened about 4 times since I got my phone, though could have happened more often I guess, as I tend to use earphones most of the time anyway.

If anyone has any ideas, I’d be so grateful.

Thank you so much for your help!

Hi there and welcome to the community!
Sorry that you received no help.

To boot in recovery to do the factory reset, once you get the No Command screen, you have to first press and hold the Power button and, after an instant, tap also on the Volume Up button (yes, a second time).

My company sell and repair Fairphone (2 and 3) since 2018. But this time i cannot fix this issue… Please help ! :slight_smile:

I cannot start a FP3, because the battery is too low, and the phone try to boot (by itself not need to press button) BEFORE the battery’s level is OK. So it stop again, just after the first “FAIRPHONE” splashscreen. And it loop : chargin fex time, then boot, failed, etc.

I found no way to start in recovery mode (only the bootloader)…
I also replace the battery with a new one, but after sometime it append again on the same FP3.
So i replace the bottom module (to be sure the battery is charging well) : same issue !

Is there a way to force the FP3 to be fully charged, BEFORE it boot ??

Thk

Charging with an external charger :man_shrugging:

I don’t understand how. Such compatible charger really exists ?
Do you plan to fix this issue, in FP3 firmware ?

Maybe, my problem is that the FP3 now read well the battery level. But which module do this level detection ? Can i replace it ?

I don’t know whether it helps with the issue, because you tried a new battery already, but at least you can recharge batteries without the phone …

Hello guys,

I had a similar experience with my FP3.

I bought it in November 2019 and since the last May I had the issue of random reboot.
The issue seems to be the SD card. If it is corrupted, for whatever reason, you have to format it and the issue should disappear.
I did it yesterday and today I have no more the random reboot.
Look forward to confirm if the issue appears again or not.

2 Likes

Hi,

I also had a reboot loop for two hours, after which one of the buttons stopped working permanently (the volume down button). So in my case I think there was a hardware error (short circuit etc) that caused the button to appear pressed even if it wasn’t.

In this case you’ll have to contact Fairphone support if you want it changed. Changing a button unfortunately requires a new core module (apart if the problem is with the frame, but it apparently wasn’t in your case).

I reply myself telling people that I had other two reboots. I still suspect it may be my SD card rather than an issue hardware. They in fact happened more rarely than before so possibly I have to change the card before blaming the hardware for this issue

Did you try to take the SD card out and use the phone for some time? Like this you would be fixed.

2 Likes

This is an idea, I have to try it

Same here, the phone starts in reboot loop for a long time, remove battery etc… And then works normally for a long time, I will send to repair, if it occurs one more time, I will report it to Paypal.

pd: I don’t have SD card.

The support team replaced me the battery

2 Likes

Thanks ! I will try your fix soon.

Dear,
I experience since last week exactly the same issue as this community member: my FP3, 4 months old, is stuck in an endless boot loop. I still have access to the help and recovery menu, but I am not able to activate the phone. There is no SD card inside, I tried both with and without SIM.
I sent a message and proof of purchase to the help desk, but receive no answer, except for an automated message with a case number. I tried to call them but hung up in despair after 13 minutes of expensive dutch waiting musique. All ideas are welcome to restore my faith in the FairPhone product and service. Thank you!

Mother board turned out to be broken. Has been replaced under warranty. thanks FP!
Good luck for those with the same problem, Philippe

3 Likes