English

FP3 not vibrating

No vibration. Both settings under notifications are turned on ("also vibrate for calls2 and “haptic vibration”) but nothing. I do remember at least haptic vibration working initially, not sure about call vibration. I turned haptic vibration off then though.

This is a bit annoying because I often do not hear my phone ringing. Any ideas anyone what might be wrong?

Thanks!

Please go to #dic:developeroptions (click to find out how to unlock it) > Service Menu > Service Tests > Test Single > Vibrator. Is the phone vibrating?

2 Likes

Hey, thanks. I was looking for that but couldn’t find info on how to turn the dev options on in FP3. Figured it out now. YES. It vibrates. So it’s a software issue??

Yes, the hardware works fine if the Vibrator Test passes. Are you sure that all other relevant settings are activated? What are your settings, e.g. for calls?

1 Like

Check all the following settings and turn them on if necessary:

  • Sounds->also vibrate for calls
  • Sounds->Advanced->other sounds and vibrations (5 options)
  • Accessibility->Vibration (2 options)

It seems the options unter sounds and accessibility have in part the same outcome, but the sliders are somewhat independent of eachother. Maybe this helps.

4 Likes

Someone had had this issue before, turned out the battery saving option was on. A tell tale sign will be that the battery icon will be red if so.

1 Like

So I’ve gone through the settings again, yes, as far as I can tell they’re all on.

  • Sounds->also vibrate for calls
  • Sounds->Advanced->other sounds and vibrations (5 options)

Update:

  • Accessibility->Vibration (2 options) - this one I didn’t know about, turned it on, now it works. Apparently that was the issue. Actually it works for calls/messages but not the haptic vibration but that’s fine since I’m going to turn it back off anyway was just for testing :nerd_face:

Thanks for your help!

1 Like

Thanks but that wasn’t it, I saw that thread too :wink:

Excellent advice, works now. See below. Apparently it was the accessibility settings (bit weird that) which I didn’t know about.

1 Like

@maakroberts For the future: Rather respond to multiple people by quoting them:

grafik

or mentioning them @username :slight_smile:

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.