FP3 not charging

Hi all! I’ve just received my Fairphone 3 and I’m unable to charge it. I’m using a brand new Samsung charger (5 V, 2 A) . When I plug it in, the battery goes up of 1% but then a message appears “connected to power but unable to charge at the moment”. This would be the first charge cycle I do for the phone. Could you please help???

From Fairphone’s Support article on the issue:

The first time you charge your phone, please use a charger that delivers at least 1 Ampere (1A, 1000mAh) and allow more than an hour for your battery to show a charge.



Still an interesting problem. I mean, @Giulia_Diano mentioned it’s a 2 Ampere charger, so why didn’t it work then nonetheless? :thinking:

My main point was the second part of the quote … keep it connected for at least one hour. It’s no guarantee that this will solve it, but it seems worth a try.


Hi Giulia,

We’ve had numerous threads about charging issues already. The short answer would probably be “It’s the cable, stupid”.

But seriously: You should use a charger which officially supports Qualcomm’s Quick Charge 3 together with a high quality, IF certified cable. I ordered mine from Fairphone itself right with my FP3 (because I think Fairphone deserved the accessory margin :wink: and both work like a charm.

Good luck, Thomas


Perhaps it’s worth to point out where this is coming from and that it’s not meant as an offense :wink: .


A bit odd perhaps for non-native English speakers.

Stupid does not address the reader/listener. It means dull in this context, and it refers to the word before it (economy, simple, cable, etc). Dull has a less negative connotation as stupid, but either way the meaning has a positive one as well. Something which is dull could be for example well understood, or easy to achieve.

Thank you for pointing this out. This was of course NOT meant as an offense.

Hello, thank you all so much for responding so quickly to my issue! I had tried to run a search on the forum through already solved posts but there was nothing specifically related to that message “connected to power but unable to charge at the moment” hence that’s why I opened a new one.

After digging the net I found out it happens when, in fact, the power delivered by the charger is too much for the device’s battery to handle and hence the flow is interrupted. Since I needed a quick fix I went out and bought a new charger and cable that fit all requirements for FP3, and now it works perfectly!

I’m happy although a bit sorry I couldn’t recycle the Samsung charger, it was actually a brand new one.

Anyway, thank you all again for the help, hope this can be a reference for anyone experiencing a similar issue :slight_smile:

P.s. @teezeh no worries at all, didn’t take that as an offence, it was indeed very dull :joy:


Thanks for writing this! I always thought my chargers are to weak, but it seems very odd for me, that the phone not simple reduce the power to the battery.
I bought new cables, but not from Fairphone. The charger was also not available at this time.
Anyhow, how can you be a “Fair and Recycle” company, if you don’t implement the ability to use nearly every cable and charger?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

I’m having the same problem with my FP3, unsresponsive after complete discharge. In my case the charging LED blinks a couple of second and then goes off. Changing charger, charging cable, battery, bottom module does not make a difference. georg

Hi Georg and welcome to the community. I moved your post to one of many posts arou d charging the FP3, as FP2 and FP3 are not really comparable.

Here you can also read around


Overall, ensure there is not debris in the USB port, cable and charger fit quick charge, when completely discharged, wait at least 30 Min vor even hours before trying to turn on.

1 Like