English

FP3 - No WiFi hotspot, USB tethering, nor VPN connection on Android 10

Hello,

After trying the /e/ OS, I wanted to switch back on Fairphone OS and discovered that it was updated to Android 10 - good news at first see.

But after the update, I’m unable to use the Wi-Fi hotspot / tethering feature, nor VPN connection (used to connect with Blokada).
To be precise I can switch on the hotspot. My other devices can see it, connect on it, but I can’t access anything on the Internet.
If I activate VPN, I’ve no problem on Wi-Fi, but no program can connect on Data.

I already tried to:

  • Check and edit APN settings: Either I completely break my connection, either nothing change. I tried copying the settings of my gf, under the same carrier (Bouygues Telecom) and offer than me and using an Android 10 phone: hotspot works for her, not for me.
  • Insert another SIM from another carrier (Orange): doesn’t work neither.
  • Reset connectivity cache and settings: no result.

While I’ve no problem access the data network on my phone, I can’t share the connection anymore. Quite problematic since I need this feature for professional usage.

Thank you in advance for your help.

There’s a similar (or same) problem mentioned here:

Unfortunately it’s partially in German and there’s not really a solution…

1 Like

Thank you for the link and the answer.
For me there is a software problem in the Fairphone Android 10, I hope the development team will update a patch soon.

I will open a support ticket, and for now switch back to Pie…

Hello,

I’m typing this over my FP3’s Wi-Fi hotspot connection and I am on Android 10, so the latter should not be the culprit for your tethering issue.

I cannot say anything about VPN, though – I simply do not use one on my phone.

As far as I understand, Blokada is rather an ad and tracking blocker than a traditional VPN. Do you have v4 or v5 of Blokada?

v5 seems to break IPv6

so if your APN is IPv6 only, this might be the reason for your connection issues. You might want to check with Bouygues if they have a Dual-Stack (DS) APN, too. For my carrier Deutsche Telekom this was the case.

Best wishes,
Thomas

1 Like

I tried both v4.8 and v5. Same problem with both versions.
I also tried other systems like DNS66 and same result.

On Android 9 I used Blokada v4.8 and no problem, with the same carrier.
On my phone the APN is in IPv4/IPv6, but on my gf’s one it’s IPv6 only. Probably that the network works in IPv6.

Did other tests with tethering on computer. Sometimes, and really sometimes, I can browse the Internet with the phone shared connection, but only the browser can connect: Windows Update, games etc. cannot reach their servers…
That looks very strange…

By the way, I don’t know if it’s related, but I don’t know what the “5” in the hotspot icon means, I didn’t find info :

If you know something, thanks in advance.

This ist the Icon für Screenrotate :wink::wink:

No, the icon for screen rotation is the first on the right.

The number on the hotspot icon stands for the respective WiFi standard:

3 Likes

Oops, You’re reight. It’ s tooo early in the Morning :grin::grin::grin:

1 Like

Thank you for the info :+1:

1 Like

Okay, so I called my carrier support today.

They told me that everything was working for them and that the problem comes from the device.
And now (how strange), hotspot works partially: browser and some apps have full Internet access on guest devices, but some others not (Dragon Mania Legends for example)

However, VPN feature is still broken.

Does it depend on whether IPv4 or IPv6 is used?

Sounds really like the IPv4/v6 issues that I experienced myself. After setting up my carriers Dual Stack APN, everything works fine.

I do not think that using alternative DNS servers still works, though. See

Best wishes,
Thomas

2 Likes

Hello guys, here are the last news:

I removed both /e/ and Fairphone OS and tried LineageOS 17 (Unofficial GSI build by fwg-cag).

At first, no Data connection at all, the apps couldn’t connect.

I checked APN settings, they were incoherent with the previous one (and I can confirm that Bouygues Telecom uses IPv6 APN, setting it to IPv4 doesn’t work).
I wanted to save the settings, but mispressed and delete the APN instead…

And, surprise! The only APN I had in the list was replaced by 3 others (Bouygues Pro, Bouygues WAP and Web) and the Data connection went back!

Tried to activate Hotspot and play Dragon Mania on my other device: the game connects. Tried the Store: OK. The browser: OK.

Installed Blokada v5, activated it: Connection still works. Perfect!

So, in conclusion, by repaired my problem totally by chance, and I can enjoy again my connection, fully.

Since I’m using a totally unofficial LineageOS build, I will try the phone features, if something goes wrong I will save APN configurations and re-apply them on Android 10 or /e/.

Thank you again for your help and for the informations. For now this problem is solved.

3 Likes