FP3+ mobile data problem

This is weird. Basic problem: no mobile data.
Background: My wife & I have identical FP3+ phones, bought 3 months ago. We use the same network provider (PlusNet). All was fine, phones had auto-updated to AOS11 first release. Then a few days ago I got a replacement for mine as an insurance claim (dropped the first one into water - don’t ask!).
I left my SIM in a spare phone while I set up the new one on WiFi only. While doing this the phone updated to the AOS11 2nd release. My wife’s phone also updated to this release and continued to work fine.
Then I put my SIM in the new phone. I got phone signal, but no mobile data. Dang.
I’ve tried all suggested fixes short of factory reset. I’m loathe to do that having spent hours re-setting-up all my apps. I’ve tried swapping SIMs with wife’s phone, her phone works with my SIM, mine doesn’t with her SIM. So there’s something up with my phone.
Is it hardware? Unlikely I would think.
There are reports of mobile data problems with AOS11 release 2, is this the issue, is there a resolution?
Totally confused - and frustrated :frowning:

Try resetting the APN settings.

1 Like

Hi and welcome to the forum.

Is this a new SIM after the other one got wet in the phone you dropped in the '^%*&^@

Also if you don’t get it fixed soon I’ll be in Plymouth and Bristol in two weeks, that’s a long time from now though :frowning:

Why didn’t you have the SIM in the phone whilst you were setting up?

1 Like

@Lidwien: done that, and everything else.

@amoun: no, original SIM. It didn’t get wet, and I put it in my old phone to keep me going while the insurance was being sorted out. Worked fine there, as it had before. That’s also why I didn’t immediately put it in the replacement phone, until I had all my stuff restored.

One difference I can think of is that the new phone updated from factory AOS10 directly to 11 release-2, whereas the other phone had gone from 10 → 11-1 → 11-2. Shouldn’t make a difference, but I’m clutching at straws.

Do FP support monitor this forum? Perhaps I need to go direct.

I’m nowhere near Plymouth or Bristol - I’m on Isle of Wight!

A little but not in a reliable sense, definetly contact to be on the safe side.

You can try a safe mode start which isn’t as serious as a factory reset it just disables all your custom apps.

Note that once Fairphone support get involved they are almost ceratinly going to ask you to do a factory reset

1 Like

Could it be that the original SIM is to old and needs to be replaced.

1 Like

Have you tried copying exactly the APN settings of your wife’s phone on yours to have both identical, then reboot?

1 Like

Thanks for all the suggestions. Endless playing with APN settings, as well as safe mode, didn’t work. Eventually I bit the bullet and did a factory reset. Bingo! All working fine. Now again going through all the setting up of app logins, widgets, payment cards, etc, which I’d just finished doing before :frowning:

Whether initially setting up the phone without a SIM, or running the AOS 10 → 11-2 also without the SIM, got it confused I don’t know - and never will!

Oh well, another one down to experience.

Cheers.

3 Likes