FP3 mobile data not working after repairs/reset

Hi, bit of a strange one: I had my phone sent in for repairs (not charging) and some parts were replaced. I got it back, but now can not get mobile data to work. Never had any problems with it before. I have used my sim-card in an older phone while waiting for the FP to get back, and have had no issues.

I have done the usual trouble shooting: Make sure APN settings are correct, try other sim-cards (same operator, other operator, they also didn´t work).
Calling and sms is working fine. Wi-fi is working fine. I have not done a full reset, I might try that but it was just reset during repairs so I´m not sure why that would work…

Using swedish operator Halebop.

Any ideas? Is this likely to be software related or could it be a hardware problem? I´ve also contacted support, but I know they have a big workload so if someone can help here, all the better. A bit bummed out, I get it back from repairs and a new issue immidiately comes up…oh well.

Some pages I have visited and followed trouble shooting advice from

Pakistan | My Mobile Data Is On But Not Working – Here’s The Fix)


For a while, with French provider Bouygues Télécom, I had a similar problem.

What worked for me was to remove all APN settings, when I did it it recreated working APN profiles.

Be careful to save current APN, as this tip doesn’t work all the time, you may have to recreate the profile manually.

By the way, did you try to reset Network settings?



1 Like

In germany there recently was a strange bug seen, when changing the SIM card, which could be fixed by inserting 2 SIM cards together and then check in the settings for “mobile data preffered card” which was set to always ask. This setting should not or at least did not exist in the past, it only existed so far for SMS and calls. So in case you should see this setting for mobile data when 2 SIM are inserted it could be fixed by selecting your SIM for mobile data and afterwards take out again the second SIM.

1 Like

please check for this new update maybe it solves the issue



Yeah what do you know, that worked. Good advice, thanks a lot!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.