FP3+: Issues with Android 13 update

Seriously it can take more than a day or two


I use the ISP-provided Zyxel T-54 router and a Zyxel 7890 WiFi access point. (WiFi 6/ Mesh)

I started the device in Safe Mode. It runs way faster in the Safe Mode, but,

  • WiFi issue still persists. It didn’t auto-connect on boot, and won’t connect at all.
  • SIM unlock prompt is still delayed, but not so much compared to normal mode.

I will wait till the weekend and see how it goes then.

  • I had to clear the Settings > System > Reset options > Reset Wi-Fi, mobile & bluetooth, on one of my two FP3s

  • I also had to temporarily enable location as in the following

1 Like

So it might be some of your installed apps.

Never heard about those router so no ideas from me end here. Any chance to test a non Zyxel network

1 Like

I’ve done this reset already. Unfortunately it didn’t help.

I also see other users having WiFi issues too: 🇩🇪 Fp3 - seit Update auf Android 13, WLAN Verbindung instabil


For my 2 cents:

For me, this update went much better than I expected.

No major hassles so far, in particular no connectivity probs, no extreme batt use, and no perf probs I may confirm, and even my tasker stuff seems to be happy with no mentionable efforts (except a bunch of std adjustments, of course).

At the end of the day, most problems I see in getting accustomed to Google’s design changes, and the immediately nasty things seem to be limited to

  • the widgets I use to show my BT connections suffering badly from the extra padding that now seems to be around text, and
  • Simple Clock’s analog widget apparently being broken big time at least with A13 and Nova.

And now for my exceptions to the above: :wink:

Delayed SIM Unlock:
This I experienced as well, with different delays every time I rebooted so far. Will see how/if this changes.

Lock Screen Quirks:
I get (in “single line” mode) another line that gives me the date, in non-“Material You” white, and (w/o any spacing) a clock symbol and a repetition of the current time plus 5 minutes. (?)

Status Bar Quirks:
In std screens, and at least with percentage enabled, it is not flush right but has an IMO nasty spacing.
Interestingly, when I expand (“pull down”), it looks as I’d expect - and gives me the current date at the left as well, though I can’t see a reason for that “bonus”.

Oops, here’s another one, concerning external inputs - and this looks like a real flaw to me:
With an external kbd attached, the bottom nav bar often goes berserk, ie. renders into plain white here, apparently backgrounding white symbols.
Cannot say atm if this only happens if “show virtual kbd” is set when there actually isn’t one for the current IME - but in A11 even this never gave any problems whatsoever.

1 Like

Delayed SIM Unlock:
Yes, I have it as well, but my device boots much faster on A13, so it looks like the modem is not fast enough registering on the network. For me there is no inconvenience here, just have to get used to it.


I just did the update today, mostly working fine. But there are a few things:

  • As others already mentioned, the phone seems to react a bit slower. Especially scrolling is laggy and stuttering. Maybe this will be better after the phone settled a few days after the upgrade and the internal optimization processes are done.

  • The removal of the screenshot option from the power menu is a bit annoying. Pressing both the power and volume down button is not really ergonomical, in my view. But I guess that’s a choice from Google and nothing what Fairphone can solve.

  • But the most visible bug is, as @rpnid already mentioned, this ugly and nasty spacing in the status bar (wrong alignment). We already had this in other OS versions of the FP3(+) and it took more than a year for Fairphone to fix it.

I know, this is not a serious functional bug, but it is so obvious, visible anytime in any app and really ugly.
If anybody knows a way to fix that, I would be very happy to know about!

  • No slowness on either of my two FP3s
  • The screenshot option sucks
  • The spacing is to allow for a green indicator when the camera is on: Of course I’m sure the notifications could be moved to the right as the green dot only occurs with the camera in action

Interesting. Did you get the updater notification about it earlier and just today initiated the update?

I’m asking because Fairphone said yesterday that they stopped the rollout.

1 Like

There should be a second Screenshot option!?


Thanks for highlighting this one. It seems indeed easier to work with.


I got the notification days before. But I decided to watch this thread for problems, before installing it.
I was not aware of the fact that the rollout was stopped.
The problem with the fingerprint reader just affects one of my apps (Bitwarden). This is very annoying because the passphrase is very long and complicated - but I decided to install the update anyway, as keeping an older Android version for a long time is not an option, too, because of security.

Thank you, I did not realize that!

I noticed that screen brightness is going crazy when in a darker environment. It always goes dark, bright, dark, etc. I hope that this “smart adaptive” automatism will learn about that.

And my old LED notification app is not working on Android 13 anymore. Where I can set individual LED colors for each app. Was not able to find a working alternative in the app store.
Anybody can recommend such an app?


Yes, there are many issues.

I don’t really know where to go at the moment. The forums seem a bit scattered all over.

My main problems:

  • some apps only start after a Very Long Time
  • some apps don’t work with the fingerprint scanner anymore
  • the device over all is just Very Slow
  • it takes ages for the sim cards to show their pin screens
  • the pull down menu from the top is very slow
  • even though I switched off all fancy gui stuff, it still doesn’t do the trick

Overall, I’m not very happy about the update. A few bugs are to be expected, but this is really a lot. My bank app (ABN AMRO) takes a gazillion years to start, which is not very convenient when you need it to login (either via the web browser on your computer or when you use it as a stand-alone app). Fortunately I still have this very old card reader lying around.

Anyway, I would love to participate somewhere in reporting bugs/hanging apps/etc., but I don’t seem to be able to find that place on the Fairphone controlled part of the internet…


That’s interesting. For me, apps are starting as quick as before.

I did not realize that this is such a huge bummer - but it is. Typing long and complicated passwords multiple times a day, instead of using the fingerprint reader, is a PITA.
I just added another app which is not working anymore here.
Hope there will be an official statement soon about how to get this situation solved.

I disabled gui animations now, too. Yes, there is no difference: It is lagging and stuttering all the time, even when just scrolling through the settings menu.

No such issue. maybe you have an app conflict

1 Like

I don’t know why I switched Bluetooth off last night, but it appeared to me that apps started faster and it felt a bit less laggy. I quickly noticed bt was off, switching it back on made some things a bit more laggy but not as bad a yesterday. Yet.

Apps which didn’t start fast yesterday still don’t start any faster.

Yeah I have Delayed SIM prompt too ; and some problems with Wi-Fi – or more specifically Wi-Fi Hotspot ; it just doesn’t launch and I need 5-10 tries to make it stick.
Else nothing of note. Whether slowness or heat or battery life… it may have changed but not dramatically.
Hope that the heavier issues are solved quickly.

Interesting, I just wanted to mention that the WiFi hotspot seems much more stable than it was! It always stalled after a while and one had to use some internet on the phone and then it would start feeding internet to the WiFi hotspot again (I was quite used using the USB tethering by now, but this is much more convenient)

Thanks for this idea. :bulb:
I tested with my local supermarket’s open WiFi, and there were no issues.
And that led me to test with home WiFi with no security.

I ran the following four test cases with my home router’s Guest AP.
Test Case 1: No security
WiFi reconnects when turned off and then on.

Test Case 2: WPA2-PSK
Reconnect works

Test Case 3: WPA3-SAE
SSID is not detected.

Test Case 4:
Initial connect works
Reconnect does not work
Password is requested upon reconnect attempt, but FP3 won’t reconnect to WiFi.

Afaik FP3 supports WiFi5 (802.11ac) but not WiFi6 (802.11ax).
It seems FP3 is failing to fall back to WPA2-PSK when both modes are supported at the same time by the router.
With the older version of Android, when FP3 detects the network it used to indicate the text “SAE transition mode”, but WiFi worked nonetheless. (WiFi is generally expected to be backwards compatible)

As a temporary solution I’ll have to switch back to WPA2-PSK in router config I guess. However, this might not work for everyone.