FP3+ does not react to anything after taking apart and reassembling

I already had touchscreen issues before and had taken it apart a few times. It got worse the day before yesterday. So I wanted to look at it again.

Yesterday, I did the following:

Device turned off.
Remove backplate.
Removed battery.
Removed SD and SIM.
Remove all screws.
Removed display with guitar pick.
Loosened the 3 ribbon cables leading to the 3 modules.
Removed all module screws.
Take the modules out.
Here comes the stupid part:
Clicked the screen back in place.
Put the battery in.
Tried to turn on the phone, nothing.
Removed battery and screen.
Put in bottom module, connect ribbon, no screws.
Screen clicked in and battery in.
Tried to power on, nothing.
Did the same with now the top module in, then the camera and lastly the speaker module.
Now with everything assembled, the phone did not respond to anything.

Plug in charger, hold power button for long time, no vibration, no light, no screen.
Then I tried to clean the silver rectangles on the back of the screen with nail polish remover on a cotton swab and then a steel/copper brush. You can see the scratches on the plastic in the photos. I also bent the hooks that were on the metal on the motherboard. Tried reconnecting the ribbon cables, didn’t help. BTW the ribbon cable that goes to the bottom module also came loose, I reconnected it to the motherboard and it seemed fine.

I noticed that 2 of the hooks of the motherboard metal covering dont go to a silver rectangle on the back of the screen. This is the hook that is the most right, and the one left to the pins. Are these supposed to go the other way, to the shields of the motherboard?

Today, took the metal motherboard covering off with screwdriver, bent the piece of metal that wasn’t really that flat which might cause the pins not making good contact. Did not help either.

Question is: Did I destroy my motherboard by trying to power the phone without any modules in?

I have an extra screen, bottom module, 2 extra batteries and there is a screen protector on both screens. I only did not test the bottom module. I did test the other screen, with the same result.

Welcome to the community forum.


Different observation

1 Like

Okay, let’s say I did not destroy the motherboard by powering on the FP without the modules:
How do I get it working again?
What worries me is that there is no vibration when trying to power on.
I tried different batteries, a different screen, and a different bottom module. It did not help.

I tried scratching the earth shield tjingies before, did nothing. Now I tried it with something different. Did I scratch too much?

I can’t help you, because I don’t understand these things. But I leave you this photo, for reference: a year ago I cleaned the ones on my FP3 and since then I have used it daily without any problems.

Best of luck :four_leaf_clover:

1 Like

I wonder if you had any vibration or status LED (before you fixed it) when trying to power it on?
Mine does not vibrate nor is there a LED light. That makes me think it is not just the screen.

I don’t remember if it had the status LED when charging, or if it vibrated when charging or receiving calls, but it probably did, since except for the issue of the screen going off throughout the day (and especially when folded, as in this video), the phone worked fine.

I’m not sure if it was the same type of problem you have, as I actually don’t recall having any issues with the touchscreen. You can read the whole thread to see what my problem was like, but I think it was quite different from yours.

Sorry I can’t be of more help, best of luck :four_leaf_clover:.