FP3 charging very slow or starts a loop when switched off

I’ve had a FP3 for a few years now, using an official FP USB wall plug charger. However, since yesterday when plugged in it it charging very slowly (from 10-40% in 24 hours) there is a charging lightning on the phone top left, but not the flashing light on the battery icon top right. If I switch it off and plug in the FP charger it starts a loop, without actually starting up it keeps flashing alternately with a white “Fairphone powered by Android” symbol and then the battery symbol - do not unplug, Fairphone is charging”.

I tried restarting.
I tried shutdown and back on.
I tried cleaning the usb port with a needle and a tiny brush.
I tried taking away the bottom module and putting it back in again.

Does anybody have any ideas please?
Should I buy a new bottom module and/or battery?

Thank you.

2 posts were merged into an existing topic: FP3 not charging - … problem now fixed :slight_smile:

I will close here and moved the comments to the other topic, to not duplicate efforts