FP3+: cannot switch off MAC randomization; WiFi connection issue


my FP3+ happily connects to several WiFi networks, my own and others. Two are on FRITZ!Box 7490 routers which I administrate.

I have recently upgraded to Android 11. Also the routers are current on FW.

I have the puzzling phenomenon that the FP3+ can still connect to all networks except for one of the above mentioned FRITZ!Box (“WiFi B”). The other FRITZ!Box (“WiFi A”) and the rest of the world work fine.

Note one major difference in “WiFi A” and “WiFi B” is that A uses the same SSID for both 2,4 and 5 GHz networks, in “WiFi B” these are separate (and I dare not change this before I can be sure this all other connected devices can follow).

“WiFi A”: single SSID, WPA2+WPA3, autochannel
“WiFi B”: separate SSIDs WPA2+WPA3, autochannel
Both same HW AVM FRITZ!Box 7490 on latest FW

effectively FP3+ ends up using “ac/Wi-Fi 5”

I already noticed that WiFi connectivity sometimes breaks after upgrades because FP3+ reverts to doing MAC randomization (which is the standard setting), and most of the networks I grant access only to “allowed” MAC addresses.
So I in these cases I need to go in settings, find the network under Saved networks and reset the FP3+ to use its own MAC address when connecting to the respective network.

Now here’s the problem:

Strangely this was not possible in “WiFi B”. The App FRITZ!WLAN would show the network IDs and even state that the networks were known (naturally, after all I had connected to them before for weeks).
But now it would not connect regardless of whether I selected the 2,4 GHz or the 5 GHz SSID.

When going to Settings and Saved WiFis it listed the 2,4 GHz network SSID. In this saved one it did state MAC randomization was on, however it would not allow me to change this, this was not editable. The 5 GHz SSID was not listed at all (despite the “known” status in FRITZ!WLAN app).

I deleted the 2,4 GHz network SSID from Saved networks and hoped to get a clean slate where my FP3+ knew nothing about either SSID and tried to reconnect.

Before connecting I was not given an option to deselect MAC randomization. I was only shown “Connect” (“Verbinden”) and that’s it.

I tried to connect as usual by using FRITZ!WLAN app to scan the QR code provided by the router. FP3+ did register connection details as when I tried repeatedly it did show me the correct password saved in the connection dialog.

The router log reported several unsuccessful connections attempts by random MAC addresses, so this showed MAC randomization was on.

I deactivated the router MAC filter setting (freeing connectivity to all MAC addresses).
My FP3+ was then readily able to connect to both SSIDs, 2,4 or 5 GHz!

Strangely these SSIDs still do not show up in the list of Saved networks!
So even now I can’t edit the saved settings to not randomize and to use the HW’s own MAC address.

So if I want to have connectivity to “WiFi B” I have to deactivate its MAC filter.

Again, this all is not an issue with “WiFi A”. FP3+ connects fine and its SSID is also shown under Saved networks, and there I can also access the MAC randomization setting to switch it on or off.

So I have these questions:

  1. Why does my FP3+ not list the suspect 2,4 and 5 GHz SSIDs under Saved networks, even after successful connection?
  2. How can I force it to show them or force MAC randomization off even before connecting?
  3. Does FP3+ have an issue with connecting to routers where 2,4 and 5 GHz SSIDs are named differently? (why would FP3+ care as the SSIDs have separate WiFi MAC addresses?)
  4. Does this have to do with the WiFi security settings (autochannel)?


I believe I understand better where this issue appears: when I try to connect to a WiFi through the Android WiFi settings themselves I first also fail, but I do get the option to access the settings to change from randomized MAC address to HW MAC address.

The issue I described above happens when I use AVM’s FRITZ!WLAN App to connect. It saves the network’s details but the Android WiFi network listing then states it is a known network and details are maintained by the app, so no edit is possible there. The app itself only reports the network as known and I find no way to change MAC settings.

Since this did work previously (that’s the way I connected to networks for as long as I can think of) I now assume this is some incompatibility or bug between AVM’s WLAN App and Android and the handover or management of WiFi data. This may have come up with the change to Android 11.

Just to let you all know where this went.
I now make initial connects to new WiFis through Android settings.


1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.