FP3 camera not working after update Android 10

After an update to Android 10, my camera stopped working. All I get is a black screen, whereas the front camera/ selfie camera works fine. How can I fix this? FP3

Hi and welcome to the forum.

When did you update from A9 to A10 as that was available some 18 months ago?

So have you really only just updated or is it only now you have a problem and you mean you are using A10 ?

Do you still have the original camera or did you change it for the 4x12MP?

You provided very little information ???

Have you tried removing and replacing the ‘rear’ camera?

What app are you using?

Do you have an SD card installed and if so hoe is it formatted.

It is more than helpful to provide more detail if not essential so that others don’t have to ask so many questions. :slight_smile:

I can see how a sudden failure may lead to a quick query. According to your profile you only read the forum for two minutes, so what info did you find in that time that may help understand the issue?

Hi, I went to config/ system / system update and there was an update. I run it.
After restarting the phone, the camera displays a black screen. The back camera / selfie camera works. I dont have details about the update, as the phone says on the system update screen that android version is 10 / security update was run on 5 march.

The reason I seem to have looked in the forum shortly is because I have 3 accounts but cannot log into the forum with the other accounts from an Ubuntu machine

Settings > About phone > Build number

But you didn’t respond to “so what info did you find in that time that may help understand the issue?”

If you have done nothing

  • try a safe mode start
  • try a factory restet

there is no ‘common’ reaon for your situation and you may want to try a few things :slight_smile: