FP3 camera not working after Android 11 update

Dear FP team,

I’m a Fairphone supporter and a proud owner of a FP 3, it has all its original pieces and has been working great so far. However, with the last system update (I believe it was the Android version 11), which I did a few days ago, my camera stopped working.

I still have the original camera, I haven’t had the need to upgrade it. I know that the update targetted mostly improvements for the FP 3+ camera, so I’m fully aware that there were no improvements for the old FP 3 camera in store, but I was also not expecting it to get worse, or in other words stop working.

In the current state after the upgrade, the camera app opens but it’s super slow and not very responsive. It takes quite some time to load and to be operational (eg. see the focus, shutter, camera options, etc.). Taking photos is still possible, but as I mentioned it is very very slow. For videos, that’s another story, it is NOT working at all!!! I tried taking videos with the front and back cameras and with both the videos were either not at all recorded/saved, got as a result just a black file impossible to open/play, or were faulty (starts reproducing but stops after a few seconds as if it were stuck).

I tried restarting the phone, also playing the videos from different players, but nothing works.
Could you please look into the issue? I was not planing on upgrading the camera, as it was working fine. Moreover, I believe that the same principle of a sustainable phone should apply also for the spare parts… why buying new ones if the existing ones are still working? These parts also become waste when replaced.

Thank you!

Kind regards,

please be aware that you cant reach official FP support here in the forum. To contact them please have a look`at #contactsupport

However maybe the community can help. Could you specify the update you have done? Under Settings-about the phone-build number


So not just the camera but you can’t play back videos.

Please check how much memory you have left and if you have an SD card I hope it is formatted as External, else . . .

In case it is a memory issue, empty the gallery bin, clear the camera storage and cache etc.

You can also try a safe mode start which disables custom apps until the next restart

But note as Yvmuell says, this forum is just other users offering ideas, it is not official support.

1 Like

Thank you. Yeah, I know, I contacted them directly as well. I wanted to share this here in case the community could also help or if someone was facing the same issue.

The build number is 8901.4.A.0021.0

It’s just the camera, the only videos I cannot play are the ones I made after the update (their format seems to be corrupted), all other videos I can play without any issue.
It is also not a memory issue, I have enough on internal and SD card (external formatted). I also tried to clear data and cache of the camera app itself without success.

Please report to support, information can be found here #contactsupport
in case troubleshooting offered here does not help.

Please dont forget to name the exact update build number you have installed.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.