English

FP3 Camera File Names including "\"?

Hi Forum,

on my new FP3, the Camera generates file names like “IMG_20201015_180654 \ .jpg”, including a back-slash. As this creates problems when syncing the images with other volumes etc. - any hints as to how I could change the way in which the images are named?

Many thanks ahead …

1 Like

This doesn’t happen on the FP3+ I have here. Have you tried to reset the Camera app to default settings (through the settings within the app)? If that doesn’t help, you could also clear the app storage through Settings > Apps & Notifications > App info > Camera … and so on (I cannot rule out though that this is actually the same action :angel: ) .

1 Like

Hi Yves,

Are you really sure that your phone generates such file names? I have never seen anything like this on my FP3, neither with Android 9 nor Android 10. Which camera app do you use, where do you store your images?

Here is a screenshot of image names on my FP3 (list view in Google Files)

Best wishes.
Thomas

2 Likes

Thanks @urs_lesse, I tried your suggestions, unfortunately, the backslashes still appear in the file names.

Hi @teezeh,

I use the default camera app on the FP3 (Camera 2.0.002), current Android 10,
then transfer the files to my Mac with Android File Transfer.

However, a look at the files while still on the phone with the File Transfer app confirms that some of the file names are generated with backslashes …

As such, I would not mind so much, but Dropbox refuses to sync files with a \ in the name.

Many thanks!

This would confirm that Android File Transfer sees the files that way, nothing more. Judging by posts in this forum Macs and Android File Transfer can be somewhat peculiar in handling Android phones (as for why, ask Apple).

Are the backslashes there when you have a look with the Files App directly in Android?
Does OpenMTP make a difference? … https://openmtp.ganeshrvel.com/

1 Like

Thanks for your reply and yes: when I look at the files with the File Transfer app on the phone (so, no computer attached), the backslashes are already there in the file names…

Which File Transfer app is this? There are many in the Play Store with file transfer in the name.

Could you use another file manager (Amaze for example) to see whether you can see the backslashes there?

Same over here. Those backslashed file names happen only every now and then without any recognizable pattern.
In my case they block the nextcloud app from auto-synching them to my nextcloud account.

For completeness sake: I tried today if different camera modes (HDR, photo, portrait, timelapse, pro etc.) made any such difference, but none resulted in file names with back slashes. I also wondered if somehow “hidden files” had been made visible in the file manager and that the files with the back slashes in their name were such, but wasn’t able to make them visible and also I seem to remember that (usually hidden) thumbnail files used to start with an underscore _

Android File Transfer is kind of the “official” app for transferring files from an Android device to a Mac. I have been using it ever since I got my FP1U six years ago.

1 Like

Thanks, I see that that’s the program to be installed on a Mac. I guess it’s an MTP client. This quote however seems to refer to an app installed on the phone and I was wondering which one that would be:

2 Likes

… it´s the app File Transfer Pro (on the phone) which is used to look at the files´names …

Thanks @urs_lesse for testing!

Same here. Not all photos have “/” in the name. I noticed that it happens when I take multiple images in a row…

2 Likes

Does the \ appear in the file names in the app “Files”?

I just tried to reproduce what you described, holding (instead of just briefly pressing) the camera app’s trigger button. The resulting file names then include the addition “_BURST000” (e.g. IMG_20201019_142023_BURST000.jpg) to “_BURST007” before the .jpg suffix. This extends the file names beyond 20 characters, maybe that results in the \ file names in some file manager apps?

@yves_ebnoether Have you checked if you see the \ backslash in the file names when you use the pre-installed “Files” app, too?

1 Like

Thanks for your testing, I agree with @petre, it does seem to happen more when I take multiple fotos in a row. @urs_lesse, I cannot find a pre-installed app called “Files” on my phone - ?

:de: Vielleicht “Dateien”? :angel:

1 Like

… ha, found it :slight_smile: but same result when looking at the files with “Dateien”, the backslashes are still there …

1 Like