FP3 Android 13: Preferred mobile data option missing

I have the new Android 13 on my Fairphone 3 now.
I already recognized that some apps with fingerprint support do not work this way anymore and there seems to be no possibility to re-enable. Ok, not nice, but I can somehow live with it.

There is another finding after the update. I cannot choose the preferred sim for mobile data anymore.
I can see that my private sim is chosen for the mobile data (sorry German screenshots).

But I cannot choose the default sim for data, only calls and sms are as an option available. (screenshot cannot be provided due to restrictions for new forum users).

Btw, switching off the mobile data on my private sim does not force the change to my company sim. Without wifi I am offline then.

Is it just me or is it a general issue?

1 Like

Hi and welcome to the community forum :slightly_smiling_face:

What happens if you swap the SIMs in their slots?

For the fingerprint question, this comes from a change of policy at Google, I don’t know that FP can do anything about it. However see:

You may be able to contribute to the list.

Yes it has to be a manual selection:

Internet > Wi-fi > select SIM

Thank you for the warm welcome.
The idea was good. Maybe it could be something locked what I could get loose by swapping. Unfortunately, I am still on my private SIM without option to change the mobile data to my company sim. :slightly_frowning_face:

Sorry, that’s why I have the issue. I can only change calls and SMS but not the mobile data (option not visible).

You dont need this setting when its only enabled at one SIM and it should only be possible to enable for one SIM. So is mobile data enabled?

Setting was enabled on both sim, and no matter which one I disabled the mobile data was not changed.
Now, I disabled both and after enabling one of them the switch over is working. :grin:
Looks like the feature was in an undefined state.


Since the recent fp3 update I cannot decide anymore whim sim I want to use to consume 3g data from. ( Or did I miss something under the new settings menu?)

The only solution I found to use data from the 2nd SIM card is to disable the SIM “profile” of the SIM card number 1, which obviously defeats the purpose of having 2 simcards…

I haven’t tried yet to switch the two SIM cards. Could it be the solution?

Please read above for further information and in my eyes it was never possible to enable mobile data at both SIM the same time.

Thanks for linking my post to this useful thread. To be clear though I didn’t mean to say it was possible to activate 3g with both simcards simultaneously. As described by @ReofSpa the issue is not being able to switch from one card to another in one click, as before.

However the workaround described above worked for me as well: deactivate mobile data on both SIMs, and then reactivate the data on the preferred sim card only. It just takes so many more steps and is quite counter-intuitive… Some UX designer failed here imho!

1 Like

Once it is enabled on 1 SIM the next time you just need to enable on the second which should automatically disable the other one, so should be not be more complicated?

Just to expand on yvmuell’s remarks. It seems that on some phones equipped with two SIMs (one of which may be an eSIM), the update to A13 messed up the settings. By disabling both SIMs (not just mobile data), and then rebooting the phone, we have seen that, after then re-enabling the SIMs, switching the choice for data from one to the other then behaves normally, and should not interfere with the choices of default SIM for making calls and sending SMS.

The FP3 has no eSIM!?


Quite right. Sorry I was confusing with a FP4 case.

Same problem here. One of my SIM cards is always the preferred option for data, no matter which slot, and the only way I can make data work on my other sim card, (the one I want to use for data) is to completely disable the SIM card that it chooses automatically - not just disable mobile data on it - I have to disable calls and SMS as well.

Almost defeats the purpose of dual sim as somebody said above.

No that doesn’t seem to be the case. I have two SIM cards. Let’s call them A and B.

I want to use A for data, but still receive calls on B and SMS on B.

The phone has decided that B is my preferred SIM for data. If I turn off data on B and keep it on on A, I still have no data. The only thing I can do is completely disable B, and no longer receive calls and SMS on it, and then data on A works.

Ah ok I understand and would advise to contactsupport if not done yet.

1 Like

This didn’t work for me. I have disabled both, even taken the sim cards out, and put them back in one by one. As soon as I put in the one that it always prefers, the problem returns

Changing slots doesn’t help. The phone seems to know which sim card it prefers independent of the slot.

Had the same problem (Very annoying, I have to reboot my phone daily and one SIM, the one I use with the data mobile created loses and therefore wasnt standard for mobile data any more).

There is no way to choose one SIM with a button to STANDARD.
My trick: SIM A (the one with data mobile) is switched on dataMobile YES. The other SIM B is NO, but is standard SIM for data mobile (I want to change this).
With SIM A: I turn off the data mobile (NO) and turn it on again. The phone ask me, if I’m sure about that. I press OK.
And voilĂ , SIM A is standard for mobile data. :smiling_face:

With SMS/ calls I say: ask me.
Because otherwise I’m searching endlessly, if I want to make a call with the other SIM :roll_eyes:
I preference with each contact seperatly.