FP3 and xprivacyLUA

Anybody out there running xprivacyLUA on his/her FP3 without any problems? On my FP3 I use Magisk 23.0, Magisk app 23.0, Riru 26.1.0, Riru-LSPosed 1.5.0 and xprivacyLUA 1.30, and xprivacy actually works, but without its protocoll function working. Sharing any experiences with working combinations will be appreciated.

Kind regards,
Januario

I’running XprivacyLua without problems, FP3+, LOS-microG 18.1, MicroG Installer MinMicroG MinimalIAP 2.20 (modified), Magisk 23.0, Riru 26.1.0, LSPosed 1.5.1, XPrivacyLua 1.30 and XprivacyLua Pro -everything works flawless besides my FP3 Microphone there I have some problems but that’s hardware no software.

1 Like

Hello Heide,
thanks for your reply. This is really important information, as my FP3 sometimes crashes completely without any discernible cause. And “reboot” nearly always results in a shutdown and no reboot; I then have to push the “on” button to restart for nearly 30 seconds. Until now, the very reboots then worked swiftly.

  1. My conjecture now is that I misdid something when I installed Magisk. Could you please tell me how you went about to install Magisk? Do you have TWRP, too?

  2. I am on “e” OS and cannot find any of “LOS-microG 18.1, MicroG Installer MinMicroG MinimalIAP 2.20 (modified)”. You think these components have anything to do with Magisk, LSPosed and XprivacyLUA?

I’ll apreciate any reply.
Januario

I’m afraid it might not comparable LineageOS works differently than e OS, but as for Magisk I had to install the Magisk apk and open it it asks for complete install flashed the .zip file asked for reboot and worked perfect. But my experience with different phones - Magisk has an addon which keeps the apps flashed via Magisk running after reboot. Unfortunately most nighties destroy part of this addon. So I figured out best way to install nightlies seems for me boot in TWRP (I have to do this via fastboot - fastboot boot twrp) wipe cache and system flash OS, flash Magisk zip and reboot. After that Magisk works perfect. Hope it helps

Thanks for your reply. If it’s more convenient for you, feel free to answer in German.

I have now some questions:

  1. How did you come by LOS-microG 18.1? Did you download it from https://lineage.microg.org/ ?

  2. I take it that you installed the MicroG Installer from within Magisk?

  3. And, very important:

a) how did you do in order to get Magisk installed in the 1st place? Did you follow the TopJohnWu official way or the (deprecated) way of installing it from within TWRP?

b) I have not managed to run Magisk and have TWRP available at the same time. How did you install TWRP?

(1) Yes I downloaded LOS-microG 18.1 at index - powered by h5ai v0.29.2 (https://larsjung.de/h5ai/)

(2) but I did not install TWRP as this creates obviously problems with the FP 3 - see below

(3) but you need as well a microG installer (at least if you need the patched Google Store, Nanodroid does not work on FP 3 with 18.1) - so I downloaded as well the MinMicroG installer of FriendlyNeighborhoodShane Releases · FriendlyNeighborhoodShane/MinMicroG_releases · GitHub - I took the version MinimalIAP because it’s not so overloaded, but added to the zip file some NLPs like DejaVue, LocalGMS, LocalWiFi, Nominatim… in ‘META-INF/system/app’ and MicroGUNLP in 'system/priv-app’from the MicroG UNLP - for me thats important te get a good location service

The procedure for me was:
I made a full wipe (but this might not be necessary),
flashed LOS-MicroG 18.1 and the respective recovery, reboot,
installed Magisk.apk, reboot in bootloader
via bootloader in TWRP (fastboot boot twrp.img - or however you name this file)
flashed Magisk.zip via twrp, reboot,
Busybox via Magisk, reboot
than I flashed the MicroG installer from FriendlyNeighbourhood via Magisk
after that Riru and Riru LSP via Magisk
and than I installed AfWall and XPrivacyLua via FDroid and activated both in LSP reboot

Hope this helps

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.