FP2 Wifi connection problems

Not much useful information to add but I have the same issue on FP2 (up to date), and that has been something new for half a year or so.

The WiFi is lost quite often or the WiFi seems connected but internet is not working, any loading gets stuck (wheter in apps or web browsing).
Other devices such as laptop don’t have those issues on the same router. And it happens in at least two different places (so two different routers, from the same provider though).

I don’t know if there has been common updates between Android 10 and 9 or the Fairphone OS for FP2 and FP3, but it looks like the same issue.

I moved your post to a new for FP2. There are already several threads for FP2 Search results for 'Fairphone 2 wifi' - Fairphone Community Forum with solutions. Can you give more information like:

  • router used
  • OS used on the FP2 in which version. Should you still use Android 7 maybe it would be a good start to upgrade to newest version (see you say up to date, but still you refer to A7). If you do so, please ensure to back-up and ensure you have enought storage free in the internal storage
  • 2.4Ghz or 5Ghz used
  • do other networks with different router work?

My bad, it is indeed Android 9 now for FP2, and I am up to date. I have OS version 21.10.0-rel2.

The FP2 is connected to 2.4Ghz WiFi but the router is providing both (on the same SSID) meaning that the phone chose the 2.4Ghz setting over the 5Ghz.
I changed that to have two separate SSIDs and forced to connect to the 5Ghz instead, I’ll see if it’s more stable.

The router is a technicolor provided by Voo (Belgium).


There’s likely a good reason, but it may not be instantly apparent.
Let us know what happens when you “force” the FP2 to use 5GHz.

I have a “work in progress” (i.e. unfinished) wiki on Wi-Fi considerations which among other things mentions a reason for devices not choosing the 5GHz band. The reason could be outdated security option. The case I discuss sounds very similar to yours.

Thanks for the tips.

I’m very close to the router in an open room, the signal (unique SSID) was showing 100% signal strength.
Now that I have separated in two SSIDs the 2.4Ghz signal is not shown at 100% strength and the 5Ghz is. Maybe it’s just because I am now connected to the 5Ghz.

I only checked the channel after I separated the SSIDs but it is in the range 36-112.
It is set on automatic but I do not see any DFS option.

The router is set on WPA2-Personal (AES).

I don’t really see any reason for the FP to choose the 2.4Ghz then.
Also, the issue in the first place is that the connection was unstable, and the Wifi was connecting again as soon as I opened the notifications menu, so I guess there is some FP OS software level involved in this behaviour.

1 Like

Just in case – do you have mobile data (4G) turned on?
Switching it off sometimes improves the WiFi connection.

1 Like

I do most of the time yes. And I did not pay attention when I am using the Wifi with no 4G. Thanks for the tip, even if it’s not very convenient.

When I need to switch I turn one off and the other on. And both off when I’m not using either. This saves on power too of course.

Neither do I but there’s likely a reason. What’s the present situation? Are you forcing the phone to only use 5GHz ? Remember, this shouldn’t be necessary, the phone should choose 5GHz anyway, as long as the network is acceptable.

[Edit] - Just realised that I have no idea what happens when you split the router to two SSIDs. Presumably in that case, you have to connect the phone to the two networks separately initially, and there’s perhaps no guarantee that later it will choose the 5GHz, unless you force it to.

Using my FP3 and a Fritzbox with two SSIDs I have the phone connected to 5GH to leave the 2.4GH band less congested for bluetooth.

If I move further from my usual location I switch to 2.4 for the longer range.

1 Like

I have the same issue that my FP2 looses its Wifi connection continuously when at home. Android 9 with the latest software update is installed. It looks as if the FP2 switches continuously between the 2,4 and 5 GHz band, a Fritzbox 7590 is used at home. How can I force the FP2 to use only one of the two bands? I could not find anything in the settings on this.

The only way is to set up 2 seperate SSIDs in the router and than connect the FP2 two both and select one at a time. The other what you can try (that helped sometimes in the past) is to set the router to 802.11 b+g only


Thanks for your help and proposal. I have tested a bit around and have found a solution which seems to work. As I mentioned before I am using a FritzBox 7590 and the phone was continuously switching between the 2,4 and 5 GHz band. I have now set the 5GHz channel selection to a fixed channel (60 in my case, it was automatic) and left the 2,4 GHz automatic channel selection unchanged. Now it seems to work and the FP2 selects the 5GHz channel and there are no more switches between the both channels. It runs stable at the moment and I will report if this is a long lasting solution.


yes there were reports as well that the FP2 does not like channels above 112 I think it was. For the sake of completeness linking an old thread Random disconnecting wifi, again - #11 by thomastc


Thanks for this tip. It did also not work with another router in Germany yesterday. Actually, there the problem started. We have a Fritz!box. Maybe my antenna does not work anymore because my problem seems the same as in the report you linked me to? I might exchange it, a friend will bring me her old FP2. Happy New Year! Juliane

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.