FP2 upgrade to Android 10 halts in Android Recovery

Was running Android 9, FP Open OS 21.12.0 with OpenGApps pico and twrp-3.6.1_9.

Using the Fairphone updater app to upgrade to Android 10, after reboots the phone shows the Android Recovery screen with options to Try again or do Factory data reset. Multiple retries to return there.

Previous upgrades from Android 6 to 7 and 7 to 9 went fine this way. Now the recovery messages are:

Fairphone/FP2/FP2 10/22.12.0-rel.0/sibon-cdd21e0c userdebug/release-keys
Cannot load Android system. Your data may be corrupt. If you continue to get this message, you may need to perform a factory data reset and erase all user data stored on this device.

I searched the forums but no topic popped up that appears to cover my problem (though I may have missed something relevant). Attempting to boot into TWRP remains stuck on the Fairphone logo screen with blue flashing LED.

Are there any options to salvage this situation without the factory reset?

I think TWRP is the problem here. To have a chance to keep your personal data, the manual installation by means of a computer seems like the only way out:

TWRP will be overwritten with the AOSP standard recovery in the process. Of course, you can reinstall TWRP once the OS upgrade has succeeded, but from my memory that will mean that the next (and final) update will renew your original problem and force you to go the manual way again.

3 Likes

You can always boot to twrp when you need it
#twrpwoflashing

3 Likes

I had a hunch this might be worth a try, thanks for confirming. The manual update went fine and the phone is up and running again. However, this is the regular FPOS with Google, most of which I didn’t really like having around (just the store app). There is no Open OS image distro, as far as I can tell?

I suppose the next best thing is then to disable the undesirable apps (as they cannot be uninstalled, generally)?

Fairphone Open files can be found here:

https://code.fairphone.com

Please check thoroughly that you download and install the right file. Some are for updating an existing Fairphone Open version and others are for switching from Fairphone OS (incl. Google) to Fairphone Open. These differ and depending on what’s on the phone at start, only one will work. By all means make sure not to install a lower version.

3 Likes

In that case, from Download Releases — FAIRPHONE open source documentation
it looks like fp2-A10-sibon-22.12.0-rel.0-manual-switcher.zip (Install Fairphone Open on a device running Fairphone OS) should be the one for my situation, would you agree?

1 Like

If I read the flashing script in it correctly, it will wipe userdata (but you will get a warning first).

The flashing script in fp2-A10-sibon-22.12.0-rel.0-manual.zip doesn’t wipe userdata, when compared to the switcher script.

1 Like

Right, but as @urs_lesse warned, that is indeed not suitable: I tried it instead of the switcher, but then rebooting halts again in Android Recovery. Back to square 1. :wink:
The upgrade zip is half the size of the full GMS OS zip, so doesn’t fully exchange FPOS for FP Open.

So after another flash round the phone is back on FPOS with GMS, now I decide whether to wipe/switch and reinstall everything (sigh), or just disable Google apps… hmm, gotta sleep on that.

Thanks both for your help so far.

1 Like

One more question about the switcher script: this wipes user data and there is presumably a good reason for that (any idea what that is?).
But the script does the wipe in two lines:

flash_image_or_abort ${sn} userdata "${IMAGES_DIR}/userdata.img"
flash_image_or_abort ${sn} cache "${IMAGES_DIR}/cache.img"

What would happen if I’d comment out those lines?

If those two lines don’t get executed, it is almost the same script as the other one. The remaining effective difference would be that this script still displays a warning about the wipe, the other script does not (see top of the script, where the warning is set to true or false).

Well of course, I got that far. But I had not yet compared the image files themselves, expecting at least some differences in what is getting flashed. That turns out not to be the case: apart from userdata.img and cache.img added to the series in the switcher script, all other images are identical.

That means commenting out those lines gives me the same result as the manual.zip file I used last night, and which halted the phone. So conversely that makes me wonder: if the manual-switcher.zip file wipes the phone, will that make a difference in bringing it back online, or will it just lock up again – minus user data this time?

If that is true (or likely) I am better off just sticking with the non-Open/GMS version of the OS, as there wouldn’t be a way to fully restore Open OS and all apps/data anyway.

A follow-up / round-up:

The link to regular FP OS with GMS (fp2-A10-gms-22.12.0-rel.0-manual.zip) was the wrong direction in my situation. According to a Fairphone dev, what could have worked was the manual upgrade of Open OS via fp2-A10-sibon-22.12.0-rel.0-manual.zip.

So I ended up starting from scratch via the switcher script, and all is well again.

I’m sorry, I overlooked that decisive detail of Fairphone OS vs. Fairphone Open in your original post.

No biggie, we all learn as we go along. And while it was a bit of a grind, rebuilding/restoring wasn’t such a bad thing after all these years (got my refurbished FP2 about 5.5 years ago).

2 Likes