FP2 updated turn off wifi services or networks

After updating my FP2 I have no choice whatsoever to access any wifi service. All wifi connectivity has disappeared, i.e. there is no list of providers in the wifi settings and I cannot turn wifi availability on again. My only option is to use data to access the internet, which is very costly.

Thanks for any suggestions. I have contacted the help desk and has been told that I was in the queue but I no indications when and how it could be solved.


Can you tell us what exactly it says in Settings - About phone - Build number now?
And …

And which OS version did you come from and was it the same OS?

It was the same OS since I bought it. I have been upgrading. The upgrade in question was on the 17th of december 2017
Hope this helpsCatalina

Thank you.
I have followed toms’ guide but unfortunately, not even following the last option of resetting restores the wifi connectivity. It is android marshmallow

  1. Navigate to Settings then Backup and reset.
  2. Select Network settings reset and then Reset settings.
  3. Once the reset is complete, attempt to reconnect to Wi-Fi.

Any other suggestions, even who should I talk at FP2 costumer services?

So you upgraded Fairphone OS with Google services from december '17 release to january '18 release just one day ago? I haven’t heard of an issue for changing between these releases, yet.

Sorry I have not been clear about the upgrade issue.
Since I upgraded my FP2 to the OS 17.12.1 version in december 2017 I have lost wifi connectivity. The turn on Wifi button automatically defaults to off. Please see image attached. The options of add network or refresh are grey. The only option in bold is Advanced.Then I have seen there is a new upgrade for FP2 OS 18.01.1, but it requires to be connected to wifi, which I cannot access yet.
Any suggestions after this?ThanksCatalina

I see you replied by e-mail, the attached image didn’t make it to the forum. Please attach the file on the forum instead if you want to show an image.

Did you already try to flash the OS manually as suggested in the other forum thread?
(The link posted there is the latest 18.01.1 version; it should not matter whether you take that one or the binary image of December.)

1 Like

Hi Albert,

Sorry I have had my mobile off as it is still of now use with the wifi connectivity.
I have tried to download the program to flash the OS manually but it ends in failure and cannot get the program into my computer.

With this are you telling me that if I update the 0S 17 to the OS 18 the problem might be solved?

No, I meant you can reinstall the OS from the computer, and the easiest way to do that is by following the instructions which point to the newest version. But in fact, version shouldn’t matter here. At which step of the process do you have a problem?

If you don’t manage to flash it, maybe one of the #fairphoneangels is located near you and can help you flash your phone?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.