FP2 unresponsive (black screen + red non-blinking LED)

Hi !
My FP2 (purchased in 2015) is unresponsive after a long period during which I did not use it (over a year and a half). As far as I remember, it was functioning correctly in the past.
Screen is black when plugged in, the charging LED is red but not blinking; behaviour is the same regardless of the presence/absence of the battery. I’ve tried 3 different chargers, at least one of which could charge another FP2 correctly.
I’ve tried swapping my modules into another FP2 and most (at least the ones I’ve tried; screen, bottom module, top module, battery) seem to be functional. Bringing in the functional modules of the other FP2 into my own (all at once) did not affect the behaviour (still a black screen, unresponsive, with a non-blinking red LED).
This leads me to think that there is an issue with the core module?
I’ve seen some instructions for repairs in cases that seem similar (FP2 dead - red light on constantly?), but they seem pretty involved, and I’m not sure to be able to follow them. I also did not find any repairshop that seems willing to take up the task (I live in Paris, France, in case anyone has a good tip!).
I’m now considering just leaving it at that, sell or give away the parts, and purchase a new phone.
But if anyone here has a suggestion that can salvage this phone, please don’t hesitate to share :slight_smile:

Have you tried charging it (without switching it on) for a longer period (20-30 minutes or more)?


hi @urs_lesse
thanks for reaching out!
yes I have, with different chargers (including on a laptop), with and without the battery.
still unresponsive after 20-30 minutes (or more).

1 Like

I had problems with my FP2 suddenly being unresponsive. I changed batteries and that seemed to cure the problem.


A post was merged into an existing topic: FP3 not charging