FP2 switches to flight mode during call

I have permanently the problem, that my FP2 switches to flight mode while I am making a call.
By holding it to my ear, the shortcut menu opens and options are selected.
This can be Bluetooth, Orientation or most of the time Flight Mode. In this case the call is terminated of course.
Is there anything, I can do to avoid this?

Basically this shouldn’t happen, as the normal behavior is that the screen should turn off during a call.

You can check if your proximity sensor works. Make a test call and check what happens when you cover your proximity sensor with a finger (the sensor is left of the speaker, in the to o of the phone. You can see it under bright light). Edit: The expected behavior is that the screen turns off.

However, when making a call, some users tend to hold the phone in a way that the proximity sensor does not get covered and the display stays on. in that case there are apps available that lock the display manually during calls.

1 Like

Thanks for the reply, I have the same problem on and off.
Pls kindly share apps you mention that can help to solve problem.

There are a couple, you can find some by looking for call screen locker.

Though since I never used one, I don’t have the experience that allows me to recommend any particular app.

Also have a look at this thread, which discusses similar problems:

Just to make sure: Did you do the latest OS updates on your phone (1.7.0 or 1.7.1)? You can check this in the Updater app.

If so, you can also try calibrating your proximity sensor. To do this, go to Settings > Maintenance > Proximity Sensor.

If this doesn’t help either (this might be due to not fully covering the proximity sensor when holding the phone to your ear), you could also switch off your screen manually when making a phone call (place your call and shortly press the On/Off button of the phone and then hold it to your ear; when ending the call you need to shortly press this button again to reactivate your screen).

Thank you for your concern.
Yes I have the latest OS version and I have checked the proximity sensor.
What I found is, that I have to hold the phone slightly differently.
The sensor is left of the speaker. When I move the phone more in direction of my face, while holding it to my ear, the problem will not occur.
I will check this for some time.

Got the same problem, but the solution seems to be quite simple. While on the phone, during a call, just shortly press the on/off button. This will block your screen until you will press that button again. You won’t accidentally switch to flight mode. No need to download any app.

Just shortly press the on/off button during a call. That should do the trick.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.