English

FP2 stuck on logo screen - rebooting does not work

Yesterday I tried to update my FP2 when I got the notification about it. Since updating it has been stuck on a logo screen saying:

FAIRPHONE
Powered by
Android

I have read various threads on this forum and have tried several times to reboot the system, but I always ended up on the logo screen again. And now Powerbutton + Volume up does not even give me the recovery options anymore, it just restarts and gives me the logo screen.

When it did show me the recovery options, it said my phone was on 21.05.0-rel.1

Any help greatly appriciated.

Does the LED blink blue while the logo is displayed? If yes you’re in #dic:fastboot mode then. It might mean the installation is broken and you could try a manual OS installation:

EDIT: you might also check if a button (e.g. vol-down) is stuck.

1 Like

The blue led light only blinks after I try press power button + volume down. Then it becomes the logo with the blue led light. Then I turn on the phone or when I press the power button + volume up, then the blue light does not blink.

update: I am back to being able to access the “reboot system now” but unfortunately, this option still restarts my phone to the logo screen (without blue light)

This really sounds as an unsuccessful boot process. So as said I’d try out the manual reinstallation of the OS. If that doesn’t help you can try a #dic:factorydatareset but this will delete all data stored on the phone.

Thank you, Volker, it worked!

Word of encouragement to others with a similar problem. While following the instructions for manual installation, I kept getting the error in step 7 and have to return to 3, so I was feeling like I was getting nowhere, but eventually my phone properly connected to my laptop, and everything worked out.

4 Likes