FP2 Screen removing impossible (sticked ?!)

Hi everyone,

I trying to remove my screen but it’s not working !
When I’m trying to slide down the screen (like it’s shown in several videos) , the screen is not moving at all; it’s like sticked to the main board… (and yes, I’ve unlocked the blue locks !)

How can I do to remove the screen without destroying anything ? (I’m living in Cambodia so impossible to get any new spare parts quickly…)

Thanks for help !

That happens frequently, when you remove the screen for the first time. It needs some ‘force’ to come loose. It’s a bit scary, but it will slide when you insist :wink:.
It helps, when you use the palm of the hand on the screen and push with it.
I’ll try to find a video that helps, I watched it, when I had the problem quite a while ago.


I tried to use some “force” indeed but maybe not enough : I don’t want the screen to be permanently removed :sweat_smile:

Check here: Fairphone 2 Display Assembly Replacement - iFixit Repair Guide
“Step 6 Another possible way of sliding the display assembly open.”


Thanks @Incanus and I haven’t tried again yet but will give a try with that method soon.

Also – I know it might sound dumb – always make sure the battery is out. I remember very well how I kept forgetting that myself.


There was i “trick”.

Turn the phone around (display downwards).
Use a thin kreditcard or similar thing, push the phone with some force against the kreditcard, that is fixed/stopped by a wall, this was the way, i opened it the fist time.
Hope, it works.


Hello all,
I tried everything and the screen was really stucked ! I really try hard, I mean with “force”. Finally the method with a ruler against a wall was the one that worked for me ! I had to use a lot of “force” to get it removed.
I think the problem was that the connectors on the screen side are a little bit oxidized.

And so I finally reach my initial goal too, that was to make something for that POWER button that was too hard to press to get the screen active. Once the screen removed, I’ve gained access to the location of the button and I’ve added a tiny thin piece a paper at the back of the button to give it more “height”. And it worked ! Now, the button has regained its sensivity :grinning:

Thanks for everybody who helped.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.