FP2 Screen can't be reactivated during/after calls - See first post for Workarounds

That’s weird… it just appears in my “all apps” list. Can you remove it and install again? Maybe that could work?

Edit… After looking at your screenshot, it seems like I have an other app!
I have this one installed: https://play.google.com/store/apps/details?id=com.mobiledirection.proximitysensorreset


the Fairphone proximity sensor app is located under Settings/Maintenance, along with the checkup and the hiccup ones.


That is quite a different app. It is by a third party.

It does attempt to do the same thing, but always to fail. I shall try again after rebooting.


I refer you to my O.P.:

“there is no maintenance section in my settings men”

What language is your phone set in? Maybe it’s not very clearly translated?
For me (in Dutch), it’s under “Onderhoud”

Thanks for your help.

The problem is now solved.

I could not find the “Maintenance” section if “Settings” because it is
masked UNLESS you are running as “Owner”. I was running as a “User”.

Your third-party tool probably failed for me for the same reason.
Unfortunately, it’s failure is silent, either because if its own design it
because the OS is not supplying a useful failure code.

Logged in as “Owner”, I reinstalled 1.10, selected “Settings | Maintenance
| Proximity” and successfully recalibrated the proximity sensor.

Dank je well nog een mal voor U hilfe!

1 Like

Can i ask if there is any fix to the proximity sensor problem. I have had a FP2 for almost a year now and then after a couple of weeks the screen went blank during a call and did not reactivate when finishing making it impossible to end the call yourself. I know the work arounds which I have used. Make the power button disconnect the call which is easier than removing the battery! and cleaning the sensor which works for a couple of days before it gets dirty again. The most annoying part is not being able to press numbers during a call when calling a company and you are confronted by a menu system requiring choices.
The problem clearly stems from the proximity sensor not being protected enough from dust etc. which is a physical error with the design of the case I guess.
Is there any hope of a fix. One possibility is to change software to be able to ignore the sensor during calls and add a lock button to the screen to prevent other buttons being pressed (default is on but can be pressed and held to release the screen).

There has been a fix implemented a few updates ago.
Just update to the latest software version and go to settings, maintenance.
There you can recalibrate your sensor.

1 Like

Thanks. It is working again!

Also clean your display properly in advance for recalibration and keep it clean as well specifically the top area where the sensor is located. These were my startup troubles until I knew better.

I can tell you for sure, mine does not.
Maybe an app crashes sometimes, but the task manager / exception handler usually knows how to take care of the situation to not have the entire OS crashing.

Hmm. Maybe they have the same problem as we…

hi there, while making a call, the display gets dark. So I cant stop the call. what to do?

1 Like

See the official support article or check here:

And if you need more tips on the matter, check out the more recent posts in this topic (I’ve moved your post to the relevant topic).

1 Like

Thanx, Johannes
from Germany

Hi Nico - You’re not alone! My screen blanks as soon as I start a call. Hugely entertaining when my on line bank tells me to “please enter your account number followed by hash…” and I can’t see the screen! Likewise, I also rip out the battery to end the call. Now I’m off to find a solution, cos I can’t use my FP2 for on line banking which is a pain. Perhaps my bank is right… try a call, fail, then ‘follow by hash’… and relax… Whatever.

This problem has been dealt with quite a while ago, see


It worked! It worked! :grinning: (I can’t find the Tick to say its sorted) Thanks, Johannes.

love you guys!!! love you guys!!! LOVE you guys!

Continues here: