FP2 Screen can't be reactivated during/after calls - See first post for Workarounds

This fix hasn’t been implemented yet into the Open OS, so it won’t work there (only in the 1.5.1).


I’ve got the same problem, no matter the way I block the sensor, it says “Block value <230…”

And I got so excited when I read the Update notes :confused:

This does not work for me. When I dial the number nothing happens after “USDD Code Running”, in other words, the calibration app is never started. And I do run version 1.5.1.


I’ve moved your post here, as the topic that you responded to was in the FP1 section. Also, it appears there was a copy/paste error in the FP2 instructions posted there by mistake. Do the instructions in the first post of this topic (here) work?

1 Like

Oh, yes, thank you, that code does indeed work. The first three times I ran it I got unblock value too high. Fourth time it actually worked. I will have to evaluate the performance during phone calls.

I’ll be back.

Edit: After testing the sensor briefly with a sensor reading app, it does seem much more responsive and accurate then pre-calibration, all tough there was quite a while ago I checked sensors readings prior to calibration. It seems promising anyway. As I said, I’ll get back to you when I tested it in some phone calls.


Sry for my bad english.

The screen of my phone turn black when i’m calling, it turn back to normal only when i remove the battery, or when the person i’m calling hang out.

I’ve read multiple topics here :

Because of my job, i need to call multiple organizations with call center where i need to press numbers to get in touch with the good departement : AND I CAN’T DO THAT!

I’ve been forced to use my previous wiko phone to call (that’s ridiculous!).

Please, did you have a real idea that works to fixe this problem.

Thank you

I’ve moved your post to the most relevant topic - there’s a description on how to recalibrate the proximity sensor in the first post; this seems to fix it for some people.

Just for info:;
I got this problem and before to recalibrate the sensor, I followed the official topic
First try to clean the sensor from dirt ! It can be deceptive, so clean it to the full :stuck_out_tongue:
It worked for me after hard try cleaning.
The app Sensors was really help full :slight_smile:
Good luck if you see this !
Kiss kiss

I have now done a few calls since I calibrated the sensor and it is much better! While it will still occasionally not turn off the screen when I put my ear to the phone, it works most of the time. I would however prefer if the sensor was disabled all together and something like the functionality of Call Screen Lock was default. Then you wouldn’t have to worry about putting the phone to your ear the right way or a certain distance.

Hi ! :slight_smile:
Whenever I receive a call or call someone, my screen just stay locked whatever the position of the phone is. I pressed the lock button, tried to orientate my phone in some ways, but it just keeps on being locked. It’s annoying when I want to end a call or when I want to activate the speakers…

Did you already try to re-calibrate your proximity sensor? (see first post)

Hi, after calibrating the “black screen issue” has been resolved. Yeah!!
Now I have the problem that I (almost) can’t reach the letter “q” and the number “1” on the keyboard anymore. It almost always highlights the letter “w” / number “2”. I am pretty sure that it started after the calibration as I didn’t notice it before. Anyone else having this issue?

I don’t recall anyone mentioning that it occurs after the calibration, but it isn’t the first time someone’s mentioned parts of the screen not responding - there’s more here:

Unless I missed something, the TL;DR version is: sometimes re-assembling the screen (detaching and then reattaching the screen module, that is) solves the issue, in some cases the screen needs to be replaced (usually under warranty; contact Fairphone support for that).


Me too: I had to try the recalibration a few times because of too high or low block or unblock values, but after it succeeded I can confirm that the proximity sensor now works as expected. Except that the distance threshold is now more like two or three cm. But as long as I don’t hold the upper left corner of the phone too far away from my ear during a call I think I should be fine. Thank you to the FP dev team!

Thanks @Johannes - sounds exactly like what I experience now. Reassembling didn’t help - and as I am in Australia, I am not sure I want to be without my phone, calendar, reminders, etc. for several weeks :frowning:

One question in the context of this post: I recalibrated, but now the app doesn’t start anymore. I wanted to do it again to check if it could have anything to do with the new issue. When I type in the last star of the calibration app’s starter code from above, the dial input field goes blank and nothing happens. I also tried force stopping the app before running the code again. Nothing. Waited for several minutes. Any other way to start it?

A definitive one-line summary for those having issues:

  • Fairphone OS 1.7.0 and Fairphone Open 16.09.0 features a proximity sensor calibration app accessible through Settings > Maintenance > Proximity sensor.

Have a look at this other thread to read more about the calibration app:


Thanks! Works like a charm :slight_smile:


It seems like the calibration tool included in 1.6.2. fixes the issue, I did a couple of tests (normal and VOIP calls) and the screen goes dark when putting the phone next to the ear and it reactivates when moving the phone away from it.

Thanks for that!


Yes, recalibrating the proximity sensor solved the problem for me. I start getting back trust in the FP project. If now the unwanted reboots will be solved soon, I am a FP2-Fan again :slight_smile:

1 Like

same, calibration helped solving the problem.
the only annoying bug left, since I upgraded to 1.4 is the ‘wait 5 seconds. bug’. Hope this can be helped soon as well!