FP2 reboots and home screen issues

Hi all,

I have owned an FP2 for five years now, and while it sometimes rebooted at will what I experienced today was totally new.

First oddity: some settings changed without me doing anything (sound on when tapping the screen as opposed to no sound, battery saving mode off as opposed to on), and two of the three buttons on the home screen stopped working - the square button that shows me my open tabs is unresponsive, and so is the round button that should take me back to the home screen. Only the arrow button works!

Second, more worrying oddity: I noticed the home screen issues and decided to check the phone settings, but whenever I tried to open a menu or tap anywhere the phone would black out and restart itself (sometimes without being able to recognise the SIM cards). At the worst times, I had one reboot every 30 sec or so.

Right now the frequency of reboots has decreased a bit, but the buttons are still not working and the phone still reboots randomly. I have two SIM cards in the phone, but removing one or the other didn’t seem to help. I tried excluding the wifi too: this might have helped decrease the frequency of reboots (although I can’t tell for sure).

Has anyone experienced anything similar on their FP2? I know there are many posts on random reboots, but I couldn’t find a description that also includes the odd behaviour I experience on the home screen.

Tips or ideas most welcome!

3 Likes

Are you using an SD card? If yes, as internal or portable memory?

2 Likes

This is very weird: something similar started to happen to me a couple of hours ago (same day!!) The phone keeps rebooting. I did not have the latest Android installed in it—is that the case for you too? I tried flashing the phone to two previous versions. The flashing was successful in theory but the awkward settings (time permanently at 10 am, no battery saving mode etc) seem to have come to stay. One thing I noticed also is that, when I plug the phone to the computer (to see whether I can save the files), it does not allow me to see the choice for “file transfer” (I don’t get to see the settings even e.g. to set flight mode on/off)
So do you have Android 9 or which one?
P.S: I also tried taking out the SD card and the SIM cards.

I’m not using an SD card at the moment, no…

Oh no, sorry to hear this! So, I didn’t install Android 9 either (actually, I have not updated the OS for a little while - I was even wondering whether that could be part of the issue). I was considering the possibility of doing what you tried - revert to a previous version, but what you say doesn’t sound very encouraging. Do you notice a different behaviour when the wifi is on or off?

Maybe there’s a general problem (starting) today (as @Otolio has mentioned) or there may something be wrong in the settings of your phone. Maybe it crashed and some data has gone corrupt?
What I’d try in your case:

  • start the phone in #dic:safemode and see if it happens there, too
  • do a full backup using TWRP (#twrpwoflashing ) and backing up all media data to a PC; then do a factory reset and see if it’s stable then
  • do an OS update (but a backup of all relevant data first!)

EDIT: btw.: did you check if internal memory still has enough free space?

3 Likes

Your problems also sound similar as the ones described here:

So maybe it’s really a problem of this very old Android 7 based OS version…

2 Likes

@GeeDee I did not notice a different behaviour by turning the wifi on or off.
@Volker the internal memory was quite full and the first thing I did was (in the lapses of time that it allowed me to do anything) erase big files, uninstall apps and move other files to the SD card (which I then removed). Still quite full but there should have been some changes IMO and it was not the case. I may keep cleaning the memory.
It is very curious to get three people with the same issue on the same day! :smiley: Not getting conspirational: I had an issue time ago with the screen behaving crazy as if someone was touching it, and it was due to some electromagnetic field that made all possible machines here not work. After 48 hours, everything went back to normal.

I have the same problem of my FP2 rebooting every 5 minutes after I found my phone empty this morning. It seems odd that more people have this problem as of today?
Any new insight to solve this problem?

2 Likes

What’s the OS version of your phone?

1 Like

After all other tries failed, I decided to reset my phone to the factory settings and to accept all the trouble it brings. Fortunately, the backup saved my Contacts and WhatsApp/Signal, but strange enough only a few apps. Had to install the other apps and re-enter the data for email-accounts etc. And to delete a lot of unnecessary and not desired apps, that always come with Google. Weird: the SD card had to be formatted again, so all data on the SD was lost.
At least I have a phone with Android 9 now, I can download apps and the home button functions. When you’re in deep shit, you can be happy with simple things. E.g., after updating the OS my corona check app didn’t work anymore, preventing access to almost everything because I was unable to generate a QR code.

2 Likes

For what it’s worth:
I’m on FP OS 19.11.2, Android 7.1.2, and I don’t have any of these issues (so far …)

4 Likes

Thanks, @adrienneb —I even checked on Twitter whether there was some alarm on this but couldn’t find any, but the fact it happened to several on the same day is still weird. How full is the memory of the phone? Maybe it is some app that some of us have which is creating the problem. I’ve uninstalled some 10 apps now and it hasn’t rebooted in a while (though other issues persist)

1 Like

In my case, plenty of both memory and storage left, so, yes, perhaps that plays a role.

1 Like

Hi Geedee,

I have the same problems as you have, they also began today (monday). I also have the same problems as mentioned in the topic which @Volker posted:

https://forum.fairphone.com/t/problems-cant-update-apps-and-more/79129

Edit:
Software specs. : Android 7.1.2 / Build 19.11.2

1 Like

Unfortunately the same happened to me today, and I came here looking for solutions (FP2, Android 7.1.2, Build number 19.11.2).

I was working this night late and my phone randomly started restarting over and over again from 02:45 CET monday morning onwards. At first it was only a few times in a row, then I could use it again for a while without problems this morning. But now my phone has been practically unusable since later this afternoon. The countless restarts drained the battery. The screen now vibrates and makes a sound when I unlock and swipe. I can’t see my home screen widget anymore. Phone may restart at any time when going through settings or opening an app. I have one Sim card inserted and one SD card. Both drives are quite full, I’ve been trying to make storage space for a few weeks but my phone doesn’t succeed at deleting big videos. They go to the bin, disappear, but then always popped back up later in their previous location. I wanted to backup my files via micro usb cable on the PC, but my PC never recognized my phone. And now it’s recharging slowly, but it loses battery life with every restart. I’m not sure what to do every tiny window I get when I can use the phone until it inevitably restarts.

You may just shut down the phone and charge it until full while being turned off.

Did anyone try to run it in #dic:safemode ? This should help to see if it’s related to an installed app.

2 Likes

Hi, I experienced a similar problem and I’m asking for help here.

What happend:

  • Sunday evening I used my FP2 until only 3% of battery was left. Put it to charge before I went to bed at 11pm (UTC+1). Phone worked fine.
  • Monday morning the phone restarts every now and then, without me doing anything. I have the impression the more load it has – app opened – the earlier it restarts. I suspected some problem with the battery. Setting the screen brightness very low seemed to help, but it was hard to get that done even. My red-filter app didn’t start, the swipe-down menu showed only one line of icons and no notifications. When opening an app the home button wouldn’t work anymore. In general the phone was not usable anymore.
  • Monday evening I thought it was a good idea to update the Fairphone OS. (I guess it wasn’t, I have no record what version I was on at that point) After downloading the image, the FP2 restarted, and at some point came into TWRP saying no OS was installed and “/system” was not found. Under “/cache” I found the image and tried to install it with TWRP “Install” option. It failed. after a reboot TWRP appeared again, but “/cache” was empty now.
  • Monday night I followed this guide to manually update the OS for my FP2. The script completed the validation but then silently was in a busy wait. I couldn’t understand why.
  • Tuesday morning I learned about fastboot and desperately ran the manual update script sudo sh flash-for-unix.sh which – this time – found my FP2 and proceeded to flash the device. It failed with the error FAILED (remote: flash write failure) when writing system. I read about differing versions of fastboot and tried the same on another machine. This time it fails at writing 'modem' with FAILED (remote: flash write failure).

My questions:

  • What does the flash write failure mean? Is there some resource on that? Does it have to do with too little space on the internal storage? How could I – at this point – free up some space?
  • What is the safest way to proceed now? Do I already have lost my data, or is it still possible to just update the system and get my apps/contacts/data restored?
  • When I flash it, it keeps giving me errors but I kept trying and eventually, one of those attempts will work (I knot it’s silly: if you do the same thing step by step, it should yield the same result, but it doesn’t in this case) That on the flashing.

  • I haven’t tried the safe mode yet or installing Android 9. I will go for those options before going to factory settings (this is really the last option for me). It seems someone lost the data in the SD card, so I suggest that, if you have one in, you take it out and then play around.

Yesterday evening, in one of the spells before reboot, I erased a bunch of apps. It would reboot after every 2 apps uninstalled. After 3 rounds of this, it stopped rebooting. I had a usable phone for a while. Decided to give it a go with the SIMs + SD. It started rebooting again (even though I took the SIMs and SD off again)
Planning on a safemode when I have time today, but if someone tries that before, let us know.