FP2 Reboot Cycle

I got a second hand FP2 which has a reboot problem. If it is switched on it starts booting. It comes to the stage where “Change is in your hands” is shown for some seconds, but then it reboots again.

I was able to install latest Fairphone Open using fastboot. So it should not be a problem related to any app. I can boot into TWRP without problems. But if I try to boot into the system this leads to the reboot cycle again.

So I believe this is not a software or installation problem, but somewhere hardware related. Any hints how I can identify the hardware component which is causing the reboot?

BTW: I’ve swapped the battery with another FP2 without a change in the behaviour. So the battery does not seem to be the problem.

I had problems with a boot loop as well, reinstalling OpenOS helped in my case :slight_smile:


As I wrote before I still had made a clean reinstall of OpenOS without success. :frowning:

@zone42 so you installed it already twice?

No I got the phone in an undefined state with the mentioned problem.

To ensure that this problem is not software related I installed a fresh OpenOS via fastboot.

But the problem still remains.

If you still have access to the other FP2, try switching the bottom module.

@Johannes speaking of bottom modules: I opened a support ticket asking for a replacement module via the form on fairphone.com a couple of days ago (so no direct email), but I didn’t receive a confirmation email. Is this normal?

@zone42 sorry if this doesn’t fit here, but I don’t want to open yet another topic regarding bottom modules, and since it is a simple yes/no question, I think it won’t distract too much from the topic here :slight_smile:

When did you open your support ticket? Less than 10 days ago?
Take a look here:

Hi there!

I’m also having troubles…

Some while back I tried to upgrade to Android 6.0, but it would never go past the boot screen. I managed to switch back to Android 5.1 and kept it running that way.

Since I bought the new camera components, I had to try upgrading again. This time I did a factory reset before flashing.

  • I tried the newest 17.11.2, flashing through fastboot: it either hangs at “starting apps…” after optimizing the apps, or on the boot screen with the blue circles going from left to right
  • I quickly tried going back to 1.13.0, flashing through fastboot: I manage to boot Android, but then I receive a lot of error messages and after seconds the phone reboots
  • I tried flashing fp2-sibon-17.11.2-manual-userdebug.zip through fastboot: I get stuck at “preparing settings”
  • I tried flashing fp2-sibon-17.11.2-ota-userdebug.zip through TWRP: I get stuck at the boot screen

I never had issues updating my FP2 through the updater, I did that maybe 3-4 times. Only with Android 6.0 I’m starting to have serious problems.

Any system modifications (root / openGapps / …)? Is the google app still enabled?
Solutions depend on your setup: e.g. if you did have openGapps installed, flash it again from recovery before booting (but after the update).

See also

Some issues are caused by incompatibilities between user data and the upgrade process (e.g. the openGAPPs case). The nuclear option (i.e. destroy the data) to solve those is, when in fastboot mode (see manual upgrade instructions):
fastboot format userdata

I just did a fastboot format userdata, followed by flashing of FP2-gms-17.11.2-manual.zip through fastboot. I still seem to be stuck on the boot screen…
Hard reset I already did… so I’m clueless as to why I’m having problems.

openGapps I never installed since I was using the non-open FP2 OS. More than a year ago I attempted to root the FP2. SuperSU would install, but I never managed to obtain root. Is this something that might cause my problems? Even after format userdata, factory reset and wipe of everything except microSD?

I’ll post the contents on the root folder in a bit.


  • boot
  • cache
  • data
  • dev
  • etc
  • external_sd
  • firmware
  • license
  • oem
  • proc
  • recovery
  • res
  • root
  • sbin
  • sdcard
  • sideload
  • supersu
  • sys
  • system
  • tmp
  • twres
  • vender


  • charger
  • default.prop
  • file_contexts
  • fstab.goldfish
  • fstab.ranchu
  • init
  • init.rc
  • init.recovery.qcom.rc
  • init.recovery.service.rc
  • init.recovery.usb.rc
  • property_contexts
  • seapp_contexts
  • selinux_version
  • sepolicy
  • service_contexts
  • ueventd.goldfish.rc
  • ueventd.qcom.rc
  • ueventd.rc

You can rule out weirdness there by trying to boot the phone without SIM card(s) and microSD card. I do remember one case where a microSD was causing issues, but I can’t find the post at the moment.


Wow… that was the problem. I would’ve never guessed that!!!
Thank you so much for your help!!!

If I insert the microSD again it won’t boot anymore again… my god, how many problems I’ve already had with FAT filesystems :frowning:


I’ve switched the bottom module without any change. :frowning:

Same with display, camera, and top module. So it seems to be a problem with the core module. Or something completely different.

Some more ideas?

You said you installed the OS again.
Did you wipe everything (except microSD) in TWRP before that?

Have you tried that yet?

1 Like

No SIM or SD-card are inserted while testing.

To be sure I did a full wipe from without TWRP and another clean install via fastboot after this. No change. :frowning:

Is there any chance to get some trace/debug output via fastboot and/or adb while booting? May be this could help identifiying the problem.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.