FP2 "pretends" to charge, no data connection possible

Hi Forum,
since two days I have the following problem: The FP2 pretends to charge, but neither the battery gets fuller nor there is the possibility to chose the setting to “data conncection”. I removed the cover, used three differnt USB-cables (on two different computers) and two power plugs as well a a power bank.
I tried also the kick-start recommended in the battery chapter, but the LED is either flashing or permanently red lighting and (after charging the battery without any phone a little bit) I could see that there was “no charging” in the battery setup displayed. But in the normal battery control page it is named “charging, full in two hours” as well as the energy safeing state is cancel at once.
I updatet my FP 2 round about two weeks ago and own it since March 2016. Any idea about that issue?
Thanks in advance!

When you attempted to kickstart the battery: Did you wait to turn on your phone until the LED was green?
Just to make sure: for the reset to properly work, the #batteryguide needs to be followed carefully.

Other than that I could only recommend to dis- and reassemble the phone (i.e. taking out the bottom module). Maybe the connections somehow got loose.


Hi Freibadschwimmer,
when I kickstarted the battery, after a certain time (round about 20 minutes @ computer, round about 5 minutes @ 2 Amps power plug) the led restarts to flash again.
Even if I tried to continue to charge the battery with a small rest of energy (round about 20 %), it lost energy…

I already disassembled the phone and cleaned all contacts as well as I tried to clean the USB-plug.

Now I have no idea what to do except sending it back or changing battery and mic module…


After 18 months, I have similar behavior.

I wonder if it is linked to the Android 6.0 update or if the bottom connector is to blame…
Following the #batteryguide the only step I did not perform was to change the bottom module because it is permanently ‘out of stock’

Same here. I plug in my FF2 to my macbook pro, and nothing. No option on the phone to select MTP, nor any sign of it on my macbook.

I had almost the exact same problem 10 days ago. In my case, it was a broken bottom module (although the microUSB-stick I used for testing that got detected). Unfortunately this is the second broken bottom module I have since in Dec. my primary microphone broke. I think there is a construction issue with those modules… :confused:

Hi Clemens, I think that’s the problem I’m faced with my phone, too. Because if I used the charged battery of another FP2, everything (except the USB-Connection, data and charging) works well. Did you get the mic module replaced on warrenty? I got my FP2 in March 2016….

I got mine in February 2016 and this is already the second bottom module I use, as I said above. I didn’t write Fairphone Support until now since @paulakreuzer, who manages the spare parts owned by the Austrian Fairphoners lives close to me and gave me a new module. I hope that I can get the money for the module from a Fairphone employee at Südwind Straßenfest in May, where Fairphone has a booth (although I’m not sure if an employee will be there such as @Douwe was last year), if not I will write an E-Mail to Support :slight_smile:
But the module with the faulty microphone got replaced by warranty in less than two weeks I think (just 3 E-Mails in total and a couple days later I got it in my hands)

I hope I could help you :slight_smile:

(By the way: Why do you know my real name? Did you visit my profile or do I know you personally? I’m not so good at keeping in mind the names of people :sweat_smile:)

Hi stanzi / Clemens,
I saw you name in my E-Mail account corresponding to the post.
I will try it on warrenty as I do not know any local “spare part dealers” in Munich unfortunately.
By the way, if I bend the USB plug carefully (but with a certain “force”) upward to the display everything (charging and data connection) works well…

1 Like

I had this effect with a different device (not a phone) once. It was not long then until the Micro USB socket became loose entirely, fell off into the device and according to the manufacturer was unrepairable, because the board was a bit broken there, too … So better be extra careful now :wink:

Personnally, I am ready to buy the bottom module (€20.16 in the spare parts shop).
I got my FP2 in January 2016 and I have a very intensive use of it, charging it multiple times a day, at hom, in the car, at the office. So I would accept that my heavy usage of the phone had started wearing the USB connector.

However, I am just diappointed that the ‘repairibility’ of the phone is prevented by this part being not available.

If there is a manufacturing issue on this part that would explain the current unavailibilty because a redesign is necessary, please @Fairphone tell us
If there is delay at the factory, please tell us
If there is another reason, … well you got the idea : tell us!

Owning a FP1 before, I was used to more transparency on what was going on (delay at factory or else). Please don’t lose that aspect, it is paramount for the relationship between @Fairphone and people owing their FP


Finally opened a ticket to support, describing exactly the issue observed and my test.
Fairphone sent me a bottom module for free. In less than a week, my FP2 is now alive and kicking again!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.