FP2 not rebooting after updating to 21 / Android 9

yes, of course (sorry, I wrote volume-Down, but meant volume-up); It does not boot successfully even after the factory-reset…, whether booting in normal or -up-way… Is there anything left, what could be done/tried? Pretty bad, what happened - complete crash of the phone - while making a normal update.

If fastboot is still able to flash TWRP or to boot it temporarily (see #twrpwoflashing), you could try to install the #modemfiles with TWRP (either directly with TWRP’s Install function if you can get the ZIP file onto the phone, or via Advanced - ADB Sideload).
If this works without errors, every partition for which there is an image in the modemfiles ZIP file would be taken care of, and flashing the rest with fastboot could be tried manually one by one.

Have you tried flashing each image manually? (open the images folder, and flash each partition with fastboot flash {partition name} {partition file} in fastboot mode)

Thanks for trying to help! But I kind of cannot use your information. I have a “bin-darwin” a “bin-msys” and an “images” folder. ok, so I open the images (?), with 11 files (boot.img, … tz.mbn) in there. but what is the partition and the {partition name}, what the {partition file}? I try to do all that in the images-folder with the promt-windows-power-shell-surface?

(while trying it with “flash-for-windows.bat” it fails always with the big files

Thanks a lot for trying to help…! :slight_smile: Although I did not get completely your second phrase (to abstract to follow…), I tried the first part. Didn’t work to flash TWPR… while flashing… information an the FP2 (I did choose the last FP2-TWRP.img):

verifying update package …
E:footer is wrong

E:Signature verification failed
E:error: 21
Installation aborted

(I tried it several times, always the same…)

(Kind of (mega) frustrated in the meanwhile from FP; no real help & support from the FP-company; most probably, I will change the company)

You can use the fastboot command like this:
For each file, it has a name (system, boot, etc), and a filename (system.img, boot.img, etc). To flash each partition manually, e.g for system.img, use fastboot flash system system.img, for tz.mbn, use fastboot flash tz tz.mbn, and repeat for each file, perhaps it will work better.

Last time I saw such symptoms was on a briccked phone, I do hope it’s not your case.

Hi, hoping someone can help. I have the same error as Axel S posted yesterday: “ERROR: Could not flash the system partition on device.”

The update didn’t work via the Updater app earlier today - my phone got stuck on the ‘Fairphone’ start screen. So I tried to manually install 21.03.0 but it didn’t work. Here’s a photo:

I also tried 19.11.2 but that gets an error immediately: “The system cannot find the path specified. ERROR: Checksums do not match, try to download the manual update again”


I have tried two laptops. My newer laptop seems to have a problem with the driver. Actually I have never connected the phone to that laptop as I’ve only had the laptop a few weeks.

I am stuck and not sure what to do next, I have spent hours trying things. I read the messages above, but I am not very techy so not sure what ‘flashing each image manually’ means, for example?

I would really appreciate some advice with this :slight_smile:

I think the relevant error message is “The system cannot find the path specified”!
Did you extract all files from the zip before starting the batch file (which you should do) - or did you start it from within a window showing the content of the zip file?

1 Like

Hi Volker, thanks for your message. Yes I extracted all the files from the zip when trying both the updates.

19.11.2 makes no difference according to the screenshot of @AxelS above.

Else … The error message you got usually is a sign for trying to run the flash-for-windows.bat inside the ZIP file (as Windows can treat it as a folder you can operate in), you would have to unzip the ZIP file first.
I hope you have a backup of all your important data before you perhaps successfully run this. It may be a downgrade at this point, and if it even works, it may require a factory reset to boot successfully.

To play it safe I would advise to contact support … https://support.fairphone.com/hc/en-us … but that is not a fast option, unfortunately. Calling them might get faster results, but not on a weekend.

I thought about what I would try in this situation … but I have a backup of my stuff before any update, so I can be intrusive and accept the loss of my data on the phone … anyway, things to try …

  • Format the system partition before trying to install again.

  • If that didn’t help … Apart from the manual install file for Fairphone OS 21.3.0-rel.2 Fairphone did release the manual switcher file to go back to Fairphone OS 21.3.0-rel.2 from Fairphone Open OS 21.3.0-rel.2 (the OS variant without preinstalled Google Apps and services). It’s herefp2-gms-21.03.0-rel.2-manual-switcher.zip.
    It’s not meant to do a complete install, I think, but the system.img is in it, and as flashing this is what’s failing now … perhaps this could do something?
    Don’t use any other file from that page, just the manual switcher file.

  • If that didn’t help either … In case it gave the same error message when flashing system, perhaps it’s the fastboot command version acting up.
    Now back to what @Alex.A already proposed …
    In the unzipped install folder, there’s a folder “images”, inside this folder you’ll find the system.img file.
    I’d try to do what the install script tries to do with it, but with a different fastboot command version.

Out of further ideas for the moment.


Files extracted from zip sounds good. Still there must be a reason for the “system cannot find path path specified” message. It must have a logic reason. Something must have been done differently during the attempts to install 21.03.0 and 19.11.2 as this is still a windows/batch execution problem and unrelated to the FP2 device…

1 Like

Thanks for the messages.

I have downloaded again but still the same error message. I deleted the previous 19.11.2 files and downloaded them again (from here: Manually install Fairphone OS for the Fairphone 2 – Support ) I extracted all from the Zip. So I am not sure why I get the ‘cannot find file path’ error.

I will see if I can try AnotherElks’s ideas, thanks.

To answer your question I downloaded the 21.03.0 files here: Manually update Fairphone OS using Windows – Support, but I guess it’s not the correct thing, thanks for letting me know! Though I was hopeful when I got further than my 19.11.2 manual attempt.

1 Like

Actually, that looks legitimate, I just didn’t look there. The offered downloads could use some consistency across the pages, I guess.
I edited my earlier post accordingly.

Ah OK. I will retry the 21.03.0 download again :slight_smile: So do you mind highlighting which tips above should I follow from your post if it fails with “ERROR: Could not flash the system partition on device” again?

I’m not in logical territory here (as what’s failing for you should work from a logical point of view, I think), so you can try all of them, even if I just compared the manual install file with the manual switcher file and fastboot.exe and system.img are the same, so I have not much hope for that one making any difference.

1 Like

it finally worked out and I could manually install the previous version. I don’t know why it succeeded this time, I already gave up one week ago and gave it one last try. Seems like my data are still there. Many thanks to all of you!


Hi - Good news, I tried the Android 7 19.11.2 manual update again this weekend, and after around 10 attempts it worked. So I have a working phone at least!

I did try the Android 9 21.03.0 manual update again, before trying the Android 7 update. It didn’t work, though it failed at a later stage this time:

“Sending sparse ‘system’ 3/4 …
Writing ‘system’ …
Fastboot error: Command failed.
Could not flash the system partition on device…”

It previously only got to 1/4.

I tried loads of times. I took the battery out and put the phone back into bootloader mode each time, but the update just didn’t work. I also changed usb cables.

So I think I will stick with 19.11.2 for now!

Thanks to you and Volker for your messages last week :slight_smile:


@scribe, @urs_lesse: Again thank you very much for your help back in April! My fairphone worked again :slight_smile: Still I have to update manually to the new version of Android. Best


Thanks for the help; sorry, that I did not respond so far. I cancelled all tries to fix the FP2; soft-brick (?); took me too much time and energy; also decrypting what really to try & do next is for non-professionals quite difficult :wink: ; anyhow thanks for your advices! because the remaining data were anyhow lost, I decided to get a FP3+ (and still hope, it will work better…); after ordering it on May 11th, I got it finally yesterday :thinking: :sweat_smile: :grinning:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.