English

FP2 not rebooting after updating to 21 / Android 9

You could ask your mobile network provider whether they could reroute calls to a phone in your office or institution temporarily.
(Hopefully there’s a landline or somebody will lend you a phone for the call.)

What got to be done, if this fails?
[finally, my FP2 even does not boot anymore, after factory-reset…]

Before, I tried to manually install via fastboot.
It mentions in the cmd.exe-Windows different things, but never anything, which leads to success:
e.g.:

** Fairphone OS 19.11.2 Manual Flashing Script **
Validating files…
All files are valid, let’s go!
One device in fastboot mode is connected.
Proceeding to flash the device.
< waiting for ??? >


or that it could not flash the rpm partition on device XYZ

2nd memory and sim-cards are out

finally, I escalated…
wipe cache partitition: no changes
factory-reset: no changes

it keep on sticking in boot loops, just showing:

“FAIRPHONE Powerded by Android” plus buzzing again and again (all about 45 sec or so)

or [in the “Power” PLUS “Volume-down”-Mode] “FAIRPHONE Powerded by Android” without buzzing but with blue light

with battery in and out,
connected, or not…

What else could be done???
Thanks for your help!

(I E-mailed the Support-Team last monday, but no reaction, so far :frowning: )

1 Like

I’m stuck in the same loop for days now… Finally I managed to put my FFP2 into fastboot mode and start the manual installtion today. I now two times recevied the message:
“Could not flash the modem partition on device xy.”

Any idea what to do now?

I neither couldn’t find “android” in the device manager. When I conntected other android devices, they appeared in the field “transportable devices”. Since I checked if these updates were ok (it didn’t work to follow the instructions and update google inc updates) I could finally connect my fairphone in fastboot mode and start the flash process, which cloudn’t finish though.

now I also tried to flash a smaller Android 5 version. Also without success. Here two jpg’s which tell a bit more, what does not work. But: what to do now?
(sorry, no jpg’s, forbidden for new users… :frowning: (Also I am actually not new, but could not log in anymore, with the account I used 2 years ago, without having changed my password)

in the “…system32\cmd.exe”-window, it is said:
sending ‘sbl1’ (274kB)… ok … writing ‘sbl1’ … ok …
sending ‘modem’ (57377kB) … Failed (data transfer failure (Unknown error)) … finished … Error: could not flash the modem partition.

The only halfway encouraging reference I’m able to find for this is this …

thanks, but not encouraging for me at all, I tried that in all combinations, with android 5 as well as 7, now for about 30 times. No way. Even the sending process of bigger data seems not to work. (Is Fairphone demanding for updates, even if the system-requirements are not sufficient?)

Thanks for all the help here on this thread. My phone also melted down today after trying to update to Android 9. So I managed to do the manual (re)install of the previous version, and my data hasn’t been lost either. I feel reluctant to try and update to Android 9 again now though, after all the stress today! Has anyone else had all these problems and got their phone up and working again with the re-install and then tried to update to 9? How has it worked out?

3 Likes

Also from me many many many thanks for the help in this thread. The update yesterday went wrong and the stress a loop can give you… but you all saved my day. Again thank you!
I’m also not to keen on trying another update and will leave it like this for now. In June I have my FP2 for 5 years and I think its time for a FP3

4 Likes

@Manon_A_Borsje @Spokes Glad it’s been useful for you. In my case, I removed some apps after getting the phone working again (just in case), and re-attempted the update to Android 9, and it went fine aside from one manual reboot. Been running Android 9 no problems since then, and just updated to the latest release without a hitch.

@AxelS @Jufi Sorry to hear it’s not been better for you. @AxelS - have you tried doing Power + Volume Up (instead of Down) at reboot, as suggested near the top of the thread?

2 Likes

yes, of course (sorry, I wrote volume-Down, but meant volume-up); It does not boot successfully even after the factory-reset…, whether booting in normal or -up-way… Is there anything left, what could be done/tried? Pretty bad, what happened - complete crash of the phone - while making a normal update.

If fastboot is still able to flash TWRP or to boot it temporarily (see #twrpwoflashing), you could try to install the #modemfiles with TWRP (either directly with TWRP’s Install function if you can get the ZIP file onto the phone, or via Advanced - ADB Sideload).
If this works without errors, every partition for which there is an image in the modemfiles ZIP file would be taken care of, and flashing the rest with fastboot could be tried manually one by one.

Have you tried flashing each image manually? (open the images folder, and flash each partition with fastboot flash {partition name} {partition file} in fastboot mode)

Thanks for trying to help! But I kind of cannot use your information. I have a “bin-darwin” a “bin-msys” and an “images” folder. ok, so I open the images (?), with 11 files (boot.img, … tz.mbn) in there. but what is the partition and the {partition name}, what the {partition file}? I try to do all that in the images-folder with the promt-windows-power-shell-surface?

(while trying it with “flash-for-windows.bat” it fails always with the big files

Thanks a lot for trying to help…! :slight_smile: Although I did not get completely your second phrase (to abstract to follow…), I tried the first part. Didn’t work to flash TWPR… while flashing… information an the FP2 (I did choose the last FP2-TWRP.img):

verifying update package …
E:footer is wrong

E:Signature verification failed
E:error: 21
Installation aborted

(I tried it several times, always the same…)

(Kind of (mega) frustrated in the meanwhile from FP; no real help & support from the FP-company; most probably, I will change the company)

You can use the fastboot command like this:
For each file, it has a name (system, boot, etc), and a filename (system.img, boot.img, etc). To flash each partition manually, e.g for system.img, use fastboot flash system system.img, for tz.mbn, use fastboot flash tz tz.mbn, and repeat for each file, perhaps it will work better.

Last time I saw such symptoms was on a briccked phone, I do hope it’s not your case.

Hi, hoping someone can help. I have the same error as Axel S posted yesterday: “ERROR: Could not flash the system partition on device.”

The update didn’t work via the Updater app earlier today - my phone got stuck on the ‘Fairphone’ start screen. So I tried to manually install 21.03.0 but it didn’t work. Here’s a photo:

I also tried 19.11.2 but that gets an error immediately: “The system cannot find the path specified. ERROR: Checksums do not match, try to download the manual update again”

image

I have tried two laptops. My newer laptop seems to have a problem with the driver. Actually I have never connected the phone to that laptop as I’ve only had the laptop a few weeks.

I am stuck and not sure what to do next, I have spent hours trying things. I read the messages above, but I am not very techy so not sure what ‘flashing each image manually’ means, for example?

I would really appreciate some advice with this :slight_smile:

I think the relevant error message is “The system cannot find the path specified”!
Did you extract all files from the zip before starting the batch file (which you should do) - or did you start it from within a window showing the content of the zip file?

1 Like

Hi Volker, thanks for your message. Yes I extracted all the files from the zip when trying both the updates.

19.11.2 makes no difference according to the screenshot of @AxelS above.

Else … The error message you got usually is a sign for trying to run the flash-for-windows.bat inside the ZIP file (as Windows can treat it as a folder you can operate in), you would have to unzip the ZIP file first.
I hope you have a backup of all your important data before you perhaps successfully run this. It may be a downgrade at this point, and if it even works, it may require a factory reset to boot successfully.

To play it safe I would advise to contact support … https://support.fairphone.com/hc/en-us … but that is not a fast option, unfortunately. Calling them might get faster results, but not on a weekend.

I thought about what I would try in this situation … but I have a backup of my stuff before any update, so I can be intrusive and accept the loss of my data on the phone … anyway, things to try …

  • Format the system partition before trying to install again.

  • If that didn’t help … Apart from the manual install file for Fairphone OS 21.3.0-rel.2 Fairphone did release the manual switcher file to go back to Fairphone OS 21.3.0-rel.2 from Fairphone Open OS 21.3.0-rel.2 (the OS variant without preinstalled Google Apps and services). It’s herefp2-gms-21.03.0-rel.2-manual-switcher.zip.
    It’s not meant to do a complete install, I think, but the system.img is in it, and as flashing this is what’s failing now … perhaps this could do something?
    Don’t use any other file from that page, just the manual switcher file.

  • If that didn’t help either … In case it gave the same error message when flashing system, perhaps it’s the fastboot command version acting up.
    Now back to what @Alex.A already proposed …
    In the unzipped install folder, there’s a folder “images”, inside this folder you’ll find the system.img file.
    I’d try to do what the install script tries to do with it, but with a different fastboot command version.

Out of further ideas for the moment.

2 Likes