FP2 not charging with USB mode "charging"

My FP2 is not charging in standard charging mode at my notebook (Lenovo T430) and the USB port in my car (Ford Fiesta). I have to change the USP option ( there appears an option to switch when you connect the FP2 to a computer via data usb cable).
Connected to my notebook, all options except the carging mode are working to charge the FP2 (MTP, PTP, mount as SDcard). So it is charging, but very, very slow, about 1% every 10 minutes.
In my car only the option mount as SDcard is working to charge the FP2, there in normal speed. But in this mode i can not play music from the SDcard via bluetooth, the SDcard is mounted :wink: But it is charging. It took me weeks to find this workaround.
And yes, the cables i’m using are ok, i’ve tested, sorted and also buyed some new cables because of the other charging issues. For me this one more bug.
Anyone else having this problems?

1 Like

I also experienced problems when charging on any of my PCs USB ports: about every second, the battery-symbol in the status bar switched from “charging” to “non-charging” and back again.

However, I am testing it again right now, and at the moment, it works fine: the battery is charged properly, and the yellow charging-LED is constantly on.
As it’s the same cable, the same USB port, the same FP2, at the moment I can only think of two possible reasons why it works now:

  1. Upcoming SW-version 1.3.0: I’ve upgraded to the new release candidate 1.3.0 recently - perhaps the new software fixes issues here? (There’s nothing on it in the list of changes, though.)
  2. Battery charged on a different level (today it’s at 85%, whereas the last time I think it was rather low)

I have the same problem. Thank you for the workaround of mounting SD-card!

1 Like

I got a MacBook and a Gaming-PC which runs with Windows. Interestingly, charging mode works on my Mac but not on my PC. I haven’t tried it out with 1.3.6 though.

I’m happy i could help someone

I had a nasty problem with “charging mode” on my FP2 which is quite similar to yours.
With “charging mode” selected as usb mode the phone didn’t charge at all - even when the phone was powered off!
It took me two weeks and a second battery (of course I thought it was because of a broken battery) to find this issue.

The only workaround which worked for me was to disable the “charging mode”…
I hope this helps if you experience that problem, too.

Thanks for your answer, but that is what i wrote in my first post as a workaround. I do not see this as a solution. In my case, it only charges in mode mount SD card, so i can not play music while charging. Now, as an other workaround, im using a usb car charger.
Is this the solution for this topic?
For me this bug is still open, but there exist this described workarounds.

Same problem here, “Charging” mode won’t charge it connected to my computer usb-plug. All other modes work for charging, even not selecting one at all (second tap deselects the current mode so that none is arrowed; @tkos maybe trying this could help with your car problem?) Turned off the phone seems to be charging, too. Using Fairphone Open 16.10 and Lenovo Z360 Laptop with Ubuntu 16.04LTS. So this problem seems not to be one of the computer operating system (as it happens with different systems), but a software/driver problem of the Fairphone.
I also have problems with my chargers (HTC 1A and Samsung 1A with different cables), although those are a little different. I’m not sure if there is a connection, but it would be interesting to hear other experiences on this. Charger problems are mainly discussed here: Charging the FP2 / cable problems

I have the same issue when connecting the FP2 (FPOS 1.9.3) to a Windows 10 PC. In charging mode it is not charging, with no mode selected it is charging. (When no mode is selected, the Android notification says “Connected as an installer”.)

This is what it looks like in Windows device manager:

Charging mode:

No mode selected:

Maybe the issue is that Windows does not find any drivers in charging mode? Does anyone have more info on QDSS CTRL / QDSS Data and the various Android devices?

I have a similar problem with my FP2 (with Fairphone OS 1.11.1), but mine only charges when connected as Camera (PTP), which I discovered because of this thread, so thanks!

This is when using a USB connected to a PC. I have another charger which plugs into the mains and that works fine.

I have a similar issue on my FP2; when I connect it by USB to a PC is is no longer charging. The difference between today (problem) and yesterday (no problem) is that I have enabled developer mode to allow USB file transfer.

Testing the other options; use USB for…

Charging - Doesn’t charge (battery icon does not show charging symbol, Batt % does not change)
File Transfer - Doesn’t charge
Photo Transfer - Doesn’t charge
MIDI - DOES charge

The OS is standard FP2 6.0.1; build 16.04

I guess you mean version 17.xx.x, because 16.xx.x is from last year. :wink:

Referring to your issue: Is USB debugging mode switched on? Either your charger or the USB cable cannot supply enough power to the phone when in this mode. Could you try another setup (charger/cable)?

1 Like

Just found this one:

Could this be a bug?

Cannot reproduce this. Works fine for me.

I have the exact same situation with my FP2. Only MIDI mode charges the phone. All others show the ‘charging’ icon for a couple of seconds and then stops charging. Has anyone found a solution for this?

If I remember correctly, I think I disabled developer mode to avoid the problem.

Not a great solution, maybe we should look into whether or not this is a repeatable problem worthy of a bug report.

Are you running latest OS?
Developer mode enabled?
Same symptoms as my post above?
Normal charging returns when developer mode disabled?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.