FP2: No Google Play Store use - no FP Updater App update - no Android 6.0 for now?

Hello Community!

I also wait for the update to Android 6.0. Unfortunatelly I haven’t got the update yet. I started the FP Updater app several times, but they still says that the OS ist the newest (OS 1.13.0).
I have strong wifi at home, so this can’t be the problem.

I read a lot of forum posts to find a solution. In some of them and in the official mail from FP is mentioned that I have to update the FP Updater App via Google Play Store. But I don’t have any Google account and I don’t want to use it. I also disabled the most google apps on my phone.

Is there an opportunity to update the Updater app upon another way to get 6.0?
Or do I have to wait until FP will send an update directly to the phone?
Do I have to do other settings on my FP2 to get the update?

Thanks for your help!


You can update the updater app via the yalp store without an account.


Thanks @paulakreuzer. I will try as soon as possible.

Hi, I also can’t update to Andorid 6.0 and believe I need to update the updater.
I can’t seem to install Yalp. A message comes up saying ‘download unsucessful’. Any advice?

If I do choose do go the Google route, which Google apps do I need to enable again? Only Google Play Store?
Thank you for your help!

That usually simply means that you had a connectivity issue during downloading. Make sure you have a stable connection and try again.

Thanks for the quick response.
I tried it many times, even restarted the phone - no luck.
Maybe tomorrow…

Try clearing the cache of the app you use to download the apk and make sure you have enough free space (you probably do). If it still doesn’t work download the file on your computer and transfer it via USB.

Hi there,
I also downloaded the updater via Yalp (Open OS, no Google stuff).
Yalp showed a message that the new version cannot be installed because the downloaded APK was signed with a different key as the installed one. The old version has to be uninstalled before.
But … the updater cannot be uninstalled as it’s a system app.
I can start the installation of the new version started but ended showing the message “App was not installed”.

Any suggestions how to update the updater?

BTW: Why does Yalp download a APK signed with a different key? That would mean Google Play should also complain about the different signatures …?

There is no Open OS version of 6.0 yet and you cannot directly crossgrade from Open OS to FP2-gms-17.04.8. You have to switch to FP2-gms76-1.13.0 first (or update manually via fastboot).

Anyone know if FP Updater App is free software? It should be, and we should also then add it to https://f-droid.org, which never requires any login or tracking to install apps.


I could update the updater here: https://play.google.com/store/apps/details?id=com.fairphone.updater

But the topic was how to update the Fairphone Updater without Google Play Store.

Wow, nice, I didn’t pick up on that!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.