FP2: mp3 as own ringtone not available with/after USB connection (solved)

I installed my own ringtone using a MP3 file.
I stored the file on the SD in media/audio/ringtones
and could select it as ringtone and it worked.
So far so good.

But after reboot, the ringtone is reset to Fairphone again.
I hope this is a bug and not a feature :wink:

BTW: you might want a specific category for FP2 bugreports :wink:

EDIT: Problem solved with this app: https://play.google.com/store/apps/details?id=com.media.ringtonemaker (It’s called Ringdroid and you can also find it on F-Droid). Open a media file with it, crop it (optionally), save it and then you can assign it as a ringtone, notification, or contact-specific ringtone. Yay!

=============================

I am also having this issue and it’s driving me crazy. On the FP1 it was just the custom ringtones for each contact, now it’s also my main ringtone and my notification sound.

Found this related thread: https://code.google.com/p/android/issues/detail?id=13413 - the issue has been reported for a long time and there’s no sight of a solution. You can install the Tone Picker app, but I created a custom Google-free image.

Meanwhile I’m experimenting with various other things: moving the ringtones to the internal storage changed nothing.

well, be careful guys, here: I tried two versions from Google Play Store: one version didn’t solve the problem (standard rintone gone after reboot) and another version has ads and aborts when I try to install the tone … ;-(

Have you guys tried an ogg file as a ring tone? On my old (well, still current) phone mp3 files caused trouble while ogg files work fine.

I tried converting mp3 to ogg. The phone couldn’t even play them.

Well, I have to clarify the problem a bit. It seems the problem is not caused by a reboot. Instead it is caused by connecting the FP2 to my laptop. This makes the SD card available in the filesystem of the laptop, but it no longer seems available for the phone. Therefore:

  • I can’t install own ringtones when the FP2 is connected via USB
  • I lose any user-defined ringtone as soon as the FP2 is connected to my USB

Can somebody help and clarify, whether this SD card visibility behavior is correct/common?
What could I do (well, I guess I need my ringtone file available in the internal memory,
which probably requires root access … )

Extension: according to one explanation in http://android.stackexchange.com/questions/22490/why-is-my-microsd-card-not-being-reconized-in-samsung-galaxy-s-plus this might be correct:

If its connected to your computer and the USB connection mode is “Mass
Storage”, the SD card cannot be used by the phone.
You may like to change the connection mode by pulling the notification
bar from top and selecting “Charge only” so that it does not mounts the
SD card and it remains usable by the phone while it is connected to PC.

OK, issue is solved: You need MTP. By default it seems FP2 has MTP mode off with USB connections and at least when using Windows the SD card is mounted instead, which means that the SD card is no longer visible to the phone with an USB connection.

You can turn on MTP in the notification that appears with each USB connection.

Note also: With MTP you have access to both Internal Memory and SD card. If you then put the mp3 file in the internal folder “ringtones” instead, you can use this ringtone and it remains valid even if MTP is turned off afterwards and the SD card is mounted again.

Hope this helps.

FP3 developers: May be MTP should by default be ON (but I am not sure).

2 Likes