FP2 lost operating system

My fp2 went black and I’m asking if someone can help me in getting it fixed… the phone proposed un update, as usual. It proceeded normally, but after the reboot it went to a mode where it had lost its operating system OS (android 7).

After the reboot I got stuck on the TWRP. It said that there is no operating system. I tried to manually install OS with these instructions :https://support.fairphone.com/hc/en-us/articles/207914363
It failed in a file called system 2/3 (2 times in same place).
After that the phone did not load TWRP anymore on boot. It got stuck on start screen (Fairphone logo). After that I tried to factory reset phone from system recovery. After boot (and removal of battery several times) phone just get stuck on Fairphone logo . Is there any way to get my phone working ? please help.

Welcome to the community forum.

It has been observed that this can be a false alarm by TWRP.
The OS still might have been there, a possible update hickup could still have been solvable at this point.

Only tried? Or really did?
If you really did a factory reset, your data on the phone would now be gone, and you could try to install the phone from scratch, see here … 🇬🇧 🇩🇪 ✏ Installing the Fairphone 2 from scratch in case of failure / Komplette Neuinstallation des Fairphone 2 im Fehlerfall.

If you have no backup of your important data, and if you are not sure about the factory reset, we should better try to get https://support.fairphone.com/hc/en-us/articles/207914363 working, since it supposedly doesn’t delete user data.

Since there can be different issues which would give different error messages, it would help if you could post the complete command line/terminal commands and their output, or screenshots.


Thank you! The factory reset was done. I will try this next!

Thank you so much! My phone is working again!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.