FP2. LED stays red. Not booting

Continuing the discussion from Led stays red while charging:

Dear Community,

I have the same issue as @Pi_Ka_Chu in the link above. I tried everything he tried and evrything @paulakreuzer suggested. Still the outcome: Screen displays nothing. Phone does not boot. No Vibration. Neither Phone nor battery get warm. Only the red LED is glowing constantly when any charger is connected (with and without inserted battery; with and without top module and camera module)

My 2-year warranty expired some weeks ago. I already subscribed to news on the availability of batteries in the store (They say batteries are back in stock in April).

Are there any ways of getting a new battery somehow? Or at least try out another battery, so i can be shure it’s the batterys fault and not the core, or bottom module?
I live in Paderborn, maybe there are some active Fairphoners in this region?

Thanks for any help,

A post was merged into an existing topic: FP2 Won’t turn on or charge - See first post for troubleshooting