FP2: Incoming calls -> screen says "loading"

Hi everybody,

whenever I receive a call to my FP2, the screen changes to bright grey and says “loading”. Sometimes it changes to the welcome screen (blue) as if the phone would be booting, and then changes quickly to the “loading”-screen.
After the caller has hung up their call, the screen turns to standby-black, then I can use it as usual. But there is no message of a missed call (neither they appear in my phone list), and the caller doesn’t get the opportunity to leave a message on my mailbox.

During the first two days after setting up my FP2, everything worked well. Then I listened to a podcast, and when a call came in, it happened for the first time as outlined above. Ever since then (4 days now) I cannot receive calls due to what I outlined above. Rebooting doesn’t help. The other way round, I can do calls myself.

Anybody facing the same problems?

Thanks and best wishes to everybody

I found the solution for my problem: I realized that the problem started right after I changed my ring tone into a self created one. As soon as I returned to one of the pre-installed ring tones, the problem was gone, and I can receive calls as usual…

Now my only task is to find a ring tone I am okay with…


1 Like

Hello jochbeck and other users,
I have noticed the same problem with my phone -
I can’t even tell you for how long it has been going on, because I just thought I had random reboots, instead of people trying to call me.

It happens on both of my sim cards - the person calling me sets my phone to “loading” so it appears switched off, or it actually sometimes reboots my phone.

This means that I can receive no incoming calls at the moment, which is super inconvenient.

Is there anyone else who’s got this problem?

I have already restarted the phone several times.


I “solved” it by reverting back to my old ring tone.
Which now makes me wonder, how on earth can this be caused by a ringtone? :wink:

@happykid please don’t post duplicates and gravedig super old topics.

This continues here: