English

FP2 in The infinitive reboot Heaven

Down on earth I’m quit happy with my FP2 and repaired it a little while ago when the usb connector was damaged.
I love the concept. FP2 rocks!

However, I seem to have a serious issue now, which I can’t resolve…

My FP2 keeps rebooting after power-up…
My FP2 seems to have left me here on earth and is in the infinitive reboot heaven

specific: power on> vibrate > logo appears(no animation) > reboot >vibrate > logo appears(no ani.)> etc.

As a last resort I decided to perform the factory reset procedure “If your Fairphone 2 doesn’t start anymore” explained: https://support.fairphone.com/hc/en-us/articles/115001610926-How-to-return-to-Factory-settings-on-my-Fairphone-2

This doesn’t help either!

I followed the procedure and followed sucesfully steps 3>4>6>8>9 and the final 10.
It keeps staying in step10 until the battery drains.

After removing battery and recharing it turns into the reboot loop again.

Wiping cache doesn’t help either.
I’m able to see log files on the screen but don’t mean much to me and I don’t see any CAPITAL texts with errors or warnings ;-(

HELP!

FP2 owner Robert

1 Like

My first suspicion would be a battery defect. Ideally you would test if the boot loop persists with another FP2 battery.

The boot loop itself doesn’t necessarily suggest any major defect in the phone itself though. It actually suggests that the bottom module’s USB port works.

1 Like

Oh, wait … did you get what you described with or without the phone being connected to the charger?

thanks for swift response. The battery seems to charge normally. The pwr led behaviour seems normally. The reboot loops continues the whole night with a battery and due to the fact that this included a short vibration after each reboot.
The phone didn’t show any battery problems.
I therefore think that the battery is okay.

ps. I tried with and without charger connected reboots. no difference in behaviour.

This is what it shows in the recovery menu:
Android Recovery
Firphone/FP2/FP2
6.0.1/FP2-gms-17.07.6/FP2-gms-17.07.6

and “Supported API: 3”

I’d try manually updating to the most recent version. 17.07.6 is quite old.
Also I’d try taking off the cover. Slim Covers (at least for a while) were known to sometimes cause reboot(loop)s if the buttons got stuck.

1 Like

thanks all for great help! I already took of the cover and will try to perform the suggested update process and let you know. Thanks all so far!
rrrRbert

1 Like

I had a similar problem, but only with certain USB cables. You may want to check if the problem stops if you use a different cable.

Since you did not have this problem before, it should’t apply to you. However, it could be that your cable got damaged enough to have a poor connection, but not so damaged that it’s completely disconnected.

Good and bad news from the Reboot Heaven.

Good:
I upgraded the FP2 to ‘the latest’ firmware.
Now it shows in the Reboot menu:
Android Recovery
Fairphone/FP2-gms-18.02.0/FP2-gms-18.02.0

Bad:
After starting (or rebooting) the FP vibrates and the FP-logo appears
I was able to follow the set-up sequence and enter SIM-pin.
During the process, the FP2 crashed again.
After rebooting (with or without charger) it sometimes is able to proceed to the startmenu and crashes or freezes.
Most of the time it reboots or freezes the initial FP2 power-up screen.

Seems its still in heaven…
Any suggestions or has this phone turned into spareparts for others ;-(

Just in case you haven’t: Have you tried starting without SIM cards and SD card?

Thx, I just tried without SIM and SD, but that does not make any difference…

Thx, I tried all cables I have. I double checked if they also work with another phone. That does not make a difference…

Other than trying wipe cache from recovery (again), I wouldn’t know what else to try. If your FP2 is less than two years old any defect could be covered by warranty - talk to Fairphone support to see what they can do (they may be slow in responding, see #contactsupport) .

Thanks, I’ll try both!

Thx, I tried all cables I have. I double checked if they also work with another phone. That does not make a difference…

Sorry to hear it wasn’t as easy to fix as that… good luck!

hey, i think i had the same problem and then i found out that my battery was loose… i had to put a paper in the gap and with that it worked…

check this link, there is a instruction
:pencil2: A little Guide to … Fairphone's Batteries (FP1 & FP2)

2 Likes

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.