English

FP2 / I can't install a new OS

Hello,

A friend gave me his fairphone 2, which didn’t boot anymore. I wanted to try to fix it but I failed.

I tried several OS (/e/, Lineage, Ubuntu Touch and Fairphone OS), but nothing worked.
I tried it with TWRP Recovery, Lineage Recovery, Fairphone Recovery.

ADB / Fastboot worked fine.

Most times it just cancelled after I used “adb sideload” with the error: 1001: failed to update system image.

With Lineage Recovery and Lineage OS (17.1.20210115-FP2-signed) my terminal stopped at 47% and Total xfer: 1.00x, the phone showed the error 1001: failed to update system image.

This manual helped a lot and the installation was completed. but the phone is now stuck in a bootloop. every 30 seconds is starts again.

I tried it with Fairphone Open and there is the same problem.

This manual helped as well, but when I used wipe function in TWRP the phone rebooted when the system was wiped.

Maybe you have some more ideas?

Hanjo

1 Like

Perhaps there’s something wrong with the partition.
The mentioned guide has an Addendum on how to format other partitions than data.
Following it, you could try to format the system partition before trying to install something again. Wiping only deletes files.

2 Likes

Thank you! I tried that and used the fairphone OS installer via fastboot. the installation was successful but the phone is again stuck in a bootloop. I made sure the battery is in a fixed position and i don’t use a phone cover so I don’t think the power button is broken.

2 Likes

I installed an older fairphone OS version (FP2-gms-18.04.1-manual), the installation was successfull but it won’t boot. There is no bootloop, just the first screen "Fairphone / Change is in your hands) and the blue dots are blinking all the time.

1 Like

Hi Hanjo,
are you sure, the battery has enough power? FP2 won’t boot if battery power is low. My first trials to install a system on an old FP2 had the same problems and that was the reason.
Best
peace

3 Likes

Thanks! Yes, the battery is fully charged.

You tried with adb sideload, but did you try copying the zip file (e.g from LOS) to an SD-card, and installing from TWRP (tap on Install, make sure you selected zip files and flash your zip)? They’re equivalent methods.
I wouldn’t put too high hopes on it but it’s worth a try.

1 Like