FP2: Headset does not work (no sound and no mic)

Hi, any others with headset problems? I tried several headsets. They are plain headsets (Sony Ericsson and Sennheiser), which had worked perfectly with my FP1. Headsets are incl. microphone, and I need them for telephone interview etc.
Thx in advance! Regina

When you say they don’t work, do you mean nothing at all (no sound from the phones, no audio picked up by the mic), or just the mic part? There’s some discussion here about partially working headsets.

Hi Johannes, I can neither listen nor use the mic of the headsets. It seems that FP2 does not “recognize” the devices. I had seen the ongoing debate, but is about the Apple compability, right? My headsets are not Apple devices, and they worked perfectly before with FP1.

I could be mistaken, but in the whole debate on audio jack standards you’d expect the headphones to always work (and you’re using a wired headset, rather than a bluetooth one, I assume).
I also recall someone posting that the headset they used on the FP1 was working on the FP2 (possibly @paulakreuzer). That, and not being able to listen to audio, makes me wonder whether you may be unlucky and have a hardware defect. If no devices are working with the phone, raise a support ticket with Fairphone staff (here) - they’ll tell you whether they have any known solutions or whether they’ll go for a warranty exchange.

With my headset the remote partially works with FP2, audio works with both phones.

Yes, my headset is wired. I really would like to avoid an exchange, as I spent a lot of time establishing my phone. I will make some more trials with various other devices and will then contact support, hoping for a distance solution. Thank you anyhow.

1 Like

My headset that I used with the FP1U is working on the FP2. The issue I have is that no icon shows up in the notification area telling me that I have a headset plugged in.

Did you have to do anything to make your headset work? Any setting, any app?

Hi everybody: We had a look at my jacksticks of the 2 headsets. They do not connect properly, as the top of the hole in FP is partly blocked by the little plate. We messured the depth of the hole, and it should be deep enough for the jackstick.
I just wrote to support and will let you knoow abou

t the solution.


2 posts were merged into an existing topic: Headset buttons do not work

15 posts were merged into an existing topic: Headset mic not working

The posts that were moved all concerned just the microphone not working.

Finally, I got response from the Fairphone support: They assume that my FP2 has a defect, probably a hardware defect. I have been offered a replacement of the phone, but I hesite choosing this solution, as everything else of my phone works fine, and I am nervous to receive a phone with other faults.
I have decided to wait for new information coming up, as I really would like to prefer keeping my topical phone, with all apps installed and all functionalities working.

You could try working something out where you try exchanging the top module, which houses the headphone connection, for a new one. Unfortunately there’s no guarantee that it will solve the problem, so I’m guessing that Fairphone support would prefer to have the phone go to their repair centre.

I havent read this entire thread, but I have massive problems with both of my headsets. One Panasonic and one Koss. This started a few weeks after i recieved my FP2, so it was not a problem from the beginning. When I listen to music etc the headset just stops working / the music stops (as if i’ve pulled the headset out), and sometimes it comes back and then goes away again. I’ve tried both headsets on other devices and its definitely the phone and not the headsets.

I also hadde problems with the screen in the beginning but it just vanished after a couple of days, so I hoped the same thing would happen here, but now it’s been like this for two weeks and it’s driving me nuts.

Anyone else having this problem? Seems like you guys have a different problem (headset not working at all)? I don’t have a qlue about different standards on headsets, i used to have a iPhone 4s and both headsets worked fine on that.

A post was merged into an existing topic: Headset mic not working