FP2 - G sensor / Accelerometer is dead

not sure when it started but since a few days I recognized that my screen is not rotating any more when changing the orientation. I checked already the settings and also the short cut for locking/unlocking the automatic screen rotation. From that point all is as it should be.
Searching through the forum and investigating a bit more I observed that an app like “labyrinth lite” (was recommended elsewhere in this forum already for calibrating the sensor) or an app called PhyPhox simply do not recognize any accelerometer in my FP2 at all (“no accelerometer found”). I have installed the latest official OS (fp os 17.10.2 - sorry, seems outdated since a few minutes :wink: ), no rooting or other specialties.

May it be related to that I had just recently replaced my display module ?

How can I further test or track down the error, how to solve it ? Has anybody else experienced such a problem ?

Much thanks in advance an regards,

1 Like

I moved the topic because it is not a general discussion about #hardware.

Could you update to 17.11.2 and then go to Settings, Maintenance and tap on Proximity sensor.
Perhaps this will help.

Hi, was there any particular reason for your advice? I just did exactly that (updating, re-calibrated the proximity sensor) and it changed…

…nothing. Somehow what I would have had expected.

Still no function on the accelerometer…

1 Like

The first thing a helpdesk will ask you is: did you apply the latest update and in case of the Fairphone did you re-calibrate. So that’s why I asked you.
I hope somebody else has an idea, if not it’s perhaps time to troubleshoot your Fairphone, or give them a call.

1 Like

I think @TimmWa wanted to know the connection between a possibly broken accelerometer and calibrating the proximity sensor.

Sensors reports the accelerometer as an STMicroelectronics LSM330D and the proximity sensor as something by vendor Intersil, so they seem not to be the same part.

1 Like

Exactly, that was a point. I did not expect that these two sensors are connected in function nor hardware.
Interestingly, I once more started SENSORS and there are only two options or devices available, I think to remember there used to be more, see attached screenshot, could someone share a similar picture with from a ‘working’ FP2?

Thanks and regards

1 Like


Hmm, time to contact the FP support, or can this be software related?? I mean any app or config that blocks all sensors??

1 Like

I don’t know if the sensors behave anything like the camera that way.
If you e.g. use a widget to turn on the flashlight you won’t be able to use a camera app before turning off the flash.
So if you have an app that might access all these sensors at once in the background than force closing or uninstalling it might work. But I rather believe it’s a hardware issue.

I see, ok.
So, I tried to uninstall the more recent installed apps (OpenCamera, PhyPhox and Data Wing), restarted the phone but no change, all sensors besides proximity, light sensor and gps are still not working.
Once more the question: may it be related to the exchange of the display module ? Where are all these sensors actually sitting ? On the mainboard ?

1 Like

Well sure if some connections inside are not aligned well since he replacement that might cause it. Have you tried reassembling and cleaning the connectors after the screen replacement?
Yes the sensors are on the mainboard afaik.

1 Like


also ‘reassembling and cleaning the connectors’ just once more did not change anything and did not help. Problem persists … What next ?

So, after some more days I could just observe the problem and did not get to a solution.
With the problem of faulty sensors (accelerometer, gravity, gyroscope, magnetic field not working/sensing) also the behaviour of some apps is strange, different or limited. E.g. taking pictures with teh FP2 now gives all pictures in portrait mode - no matter how the phone was oriented when taking the picture. Displaying videos is not possible in landscape modus. The camera app of the FP2 doesn’t offer any panorama assistants any more and so on…
Is there any idea or test or action to do before asking for a replacement ?
Thanks and regards,


Well if you wanted to get radical, you could wipe the whole phone clean (erasing the OS and all data on the phone) and install the OS from scratch … if the sensors stay dead afterwards, that should confirm hardware failure.

1 Like

Puhhh, this seems much too radical to me up to now. I am a bit reluctant to again set up my phone from scratch, had too often already to live with a limited FP2 or waiting for replacments or setting it up from zero… I might first talk to the helpdesk…

But thanks for the reply,

1 Like


I was observing the problem for a while when deciding mid December to open a ticket at Support (Request #219970). During the last weeks it became more and more pronounced how limited a ‘Smart Phone’ with all these dead sensors is at all - not too much smartness left. Hence, it is hardly usable and now I am waiting since four weeks for any response from support - which is heavily annoying. What can be done ?

I do have the same problem. FP2 Board 17.12.2015 Accelerometer stopped working. Complete wipe of the phone did not help…

OS: FP2-gms- 18.02.0

Hi, this is very interesting. Could you trace down the problem when or why it happened to you? Which sensors are affected, can you share a screenshot? I have no clue or idea what this problem may have caused.
Last week I also received the first(!) Response on my support ticket - exchanging and asking for formalities. Still fully open to me what and when solution might be available… Starting to wonder whether I should change to a different phone ?