FP2: Fairphone OS & Fairphone Open 22.02.0-rel.0 (Android 10)

,

Did you try to delete cache and data of the updater?

No. How do I do that ?

Settings->apps->updater->storage and cache->delete storage

2 Likes

ok - have done that.

No change - Updater says “Download started” - “Just a moment”. Nothing happens - then reverts to the Opening screen.

do you use anything like Netguard?

4 Likes

…or do you use a pihole blocking some sites as mentioned here?

3 Likes

No - not AFAIK. All worked ok for previous upgrades…

No - not AFAIK. All worked ok on previous upgrades.

Memory space ?

How full is your storage and do you use an SD card and if yes how is it formatted (internal vs portable)?

2 Likes

Did you try not only deleting cache but also deleting storage of the updater?

Yes - I did.

I am suspicious that I do not have enough free memory space… How can I tell?

Enable the #dic:developeroptions and it’s the first entry in them AFAIK.

Thanks for the quick reply. But I have no idea what you mean. How do I enable #dic:developments ?
Sorry - not that familiar with Android OS. Was going to suck all my photos off…Have purchased a Memory card - and shifted photos to it - but don’t seem to be able to tell Camera to put new photos on the card…?

#dic:developeroptions is a link to a guide on the forum that should explain it :wink:

Very important: did you format it as internal storage (first option) or as external storage (second option)? If the former, please copy back all your photos and reformat your card as external storage before using it as it can create many problems as internal. Please see the #sdcardguide for information.

No, it’s indeed impossible. You’d need a 3rd party camera for this, such as OpenCamera (or regularly copy your photos manually).

3 Likes

ok - thanks for this. No idea why so much internal storage is used. I am deleting photos - but they cannot be responsible for the large storage consumption. No videos, no music.

Now Updater has decided that my FP2 is Up-to-date (Android 9) after telling me for days that I needed to update to Android 10…Have done a Restart. Same story: Up-to-Date.

I delayed the update of my FP2 (FP OS 21.12.0-rel. 1) to the new Android 10 release (OS 22.02.0-rel.0) until today (I basically ignored the previous update notifications because I wanted to be sure that there are no unsolved problems). But now starting my Fairphone Updater App (release 1.50.5) it tells me that 21.12.0-rel. 1 is the most actual release. How can I get the updater to provide me with the newest release? I already deleted the cache and date of the updater app with no result. Help is very much appreciated.

Thanks for reporting @planetcooler and @Michael_Weber, can you try again to see if the upgrade to Android 10 is available now?

2 Likes

I just tried again a couple of minutes ago and now I can see the upgrade message in the updater :smiley: Thx a lot! Could you briefly explain what had been the reason for this behaviour? Anyway, I’ll instantly do the upgrade!

Some configuration was missing on the server side after we completed the staged rollout of Android 10.

4 Likes

I understand. I’m really grateful for your speedy support. One reason more to buy my next phone with Fairphone :+1:

3 Likes