English

FP2: Fairphone OS 19.05.3 release

nougat
Tags: #<Tag:0x00007fefc24e3e00>

#44

I got the famous blue arrow “teamwin” / “Recovery Project 3.1.1-0” screen now as on the last update, i.e. the Fairphone Updater app is not working. So a .zip file (binary image) is necessary in that case to use the manual process as on the previous update.


#45

Worth a try when in TWRP …

A little more detail in between …


#46

Please note: This double arrow screen does NOT show any kind of button. All I can do is to press the power butten several seconds so the phone boots with the current 19.02.1 OS (this is working without any issues).

Note: I downloaded this TWRP file using the official app and I also can see it on the Total Commander (file browser app) but there is no action how to install it.



#47

If both the “App Install Method” and the “TWRP Install” fail, there’s still the “Fastboot Install Method” … https://twrp.me/fairphone/fairphone2.html


#48

Hi everybody! When I try to update my FP2 to 19.05.3 via the updater app the update fails and I end up in TWRP. The recovery.log says:

E3001: Package expects build fingerprint of Fairphone/FP2/FP2:7.1.2/19.02.1/gms-dc48370a:user/release-keys or Fairphone/FP2/FP2:7.1.2/19.05.3/gms-404195ba:user/release-keys; this device has Fairphone/omni_FP2/FP2:6.0.1/MOB30M/13:eng/test-keys.

However, my phone’s current OS is 7.1.2 - 19.02.1 as can be seen from the settings as well as the updater app:


The only thing I tinkered with is my recovery - I replaced the original TWRP version 3.1.1 with the newer version 3.2.3, because the older version wasn’t able to produce reasonable backups.

Does anyone have an idea what might be wrong?

Thank you in advance, Christian


#49

This sounds like the value for TWRP itself, not for the OS.

Worth a try when in TWRP …

A little more detail in between …


#50

Thank you for this idea, AnotherElk! I tried this already - it gives me the same result, unfortunately.

Any idea, why TWRP is using the TWRP fingerprint instead of the OS fingerprint for compatibility check?


#51

During the Update to 19.05.03, the same issue occured on my Fairphone 2. I didn’t know what to do, so I tried “reboot”, which wasn’t the best idea. After the reboot the Fairphone didn’t boot anymore.
I was able to reinstall the OS via fastboot. Unfortunately I didn’t find the files for 19.05.3 for the manual update. So I gave the updater App another chance and it worked fine. Obviously anything went wrong in the first try. No big deal at all.


#52

What I was able to find out so far: The build fingerprint TWRP is using is the “ro.build.fingerprint” from /default.prop. The (correct) build fingerprint TWRP should use is the “ro.build.fingerprint” from /system/build.prop.

So the next question is: Why doesn’t TWRP load /system/build.prop and uses /default.prop instead?


#53

The answer to that is ~40 posts up :wink:


#55

I have found the full manual file is at https: storage.googleapis dot com/fairphone-updates/9f2f1881-211e-4f6b-bddd-11856b256de3/fp2-gms-19.05.3-manual.zip (warning: this one must erase your phone to properly install via a host computer: be warned).
[ please note the low cost / low privacy web hosting company… : Fairphone is definitly good at ethical materials, but not good in software ethics; another story…]

MD5 (fp2-gms-19.05.3-manual.zip) = 6976851286ad321a8e07e3e60b683ecd
SHA1 (fp2-gms-19.05.3-manual.zip) = 96845b9b3dfc12d655c597dc00f47d7974b7d711
SHA256 (fp2-gms-19.05.3-manual.zip) = 2e255ba40c2f9e1d0c191a5f5dc86467f5a3ce6000c589110c91de72e872d56e
SHA512 (fp2-gms-19.02.1-manual.zip) = 02b202c8a261ed032c07d5342cc1d7acc1ea656b436818f69798a08a21f4a28e03faee0d8d0b0f02979bfe9cbaa4cf283fb0e312c1f2245b21bc60717fa7f320

[ found from “bruteforce-testing” the urls on : https: code.fairphone dot com/projects/fp-osos/user/fairphone-open-source-os-downloads.html ]


While I had luck yesterday seeking & correcting this infamous fairphone bug on my daughter’s FP2, I have grabbed the /cache/fp_update_gms-404195ba.zip for whom it can help: http:dl.free.fr/qAApbVaut (dl.free DOT fr is a french equivalent of wetransfer or mega service; nothing to worry about…).

If it can help, save this file to an sdcard or usb-pendrive if you have an otg cable, mount the pendrive or the sdcard in twrp/advanced/mount then install the upgrade via this file.

MD5 (fp_update_gms-404195ba.zip) = 7585004f1d0336a22253acaff5b9836f
SHA256 (fp_update_gms-404195ba.zip) = 5400a0ef41a19ca4603c51cb5ca053a0ca6b64915641bbfbee71e651543ca208

by experience, your phone must have at least 3Gbytes free on it; This “fp_update” will not erase the phone; and it’s the 19.5.3

PS: I’m not a fairphone employee. My opinions expressed here are only mine.


#56

Thank you for your response RSpliet!
Unfortunately, the clue that your idea is not right is just 5 posts up :wink:. As I said, I replaced my recovery with TWRP 3.2.3. In this version the "Unable to find /system’ bug is solved. I don’t have this message in the log and I am able to mount /system manually in TWRP. I also tried to install 19.05.3 after mounting /system manually, but still no success.
Actually, in the contrary, those guys with the original TWRP 3.1.1 and the "Unable to find /system’ bug in it seem to be able to install the update smoothly in most instances.

Thank you anyway! Christian


#57

This one did work for me!
Thanks a lot, AnotherElk!


#58

I am a bit scared of doing the update now after skimming through this thread. Can somebody please clarify/summarise, if the update commonly causes issues (when using the updater app)? And if yes, how to avoid/fix them?


#59

@holzfaeller15 People were having more trouble than usual after a failed update, because the files for a manual update were not available yet. However 19.05.3 has now appeared on the manual installation guide. If your update goes wrong, you can now use that guide to get it anyway.


#60

I was a bit scared too… So I made a backup with TWRP and startet the update via the updater app. Everything went smooth and I’m on Fairphone OS 19.05.3 release now :smiley:. I’m on TWRP 3.1.1.0 without ZIP signature verification. My phone is not encrypted and I don’t use xposed. During the update I saw briefly the TWRP screen and the message “unable to find partition for path ‘/system’”
Thanks to the fairphone software team for their ongoing support!