FP2: Fairphone Open 19.11.2 release

I tried this.
C:\Users\gerbr\Documents\ADB\platform-tools>fastboot flash recovery twrp-3.3.1-0-FP2.img
Sending ‘recovery’ (10386 KB) OKAY [ 0.354s]
Writing ‘recovery’ OKAY [ 0.247s]
Finished. Total time: 0.616s

Still I get AOSP recovery when booting in recovery mode. Not able to install opengapps: signature verification fails and I have no idea how to circumvent this in AOSP :frowning:

After a newer TWRP got installed, you have to reboot right into the newer TWRP to let it make itself resident. If the OS gets rebooted first instead, it will restore its own recovery.

In the TWRP install guide, this is “Note many devices will replace your custom recovery automatically during first boot. To prevent this, use Google to find the proper key combo to enter recovery. After typing fastboot reboot, hold the key combo and boot to TWRP. Once TWRP is booted, TWRP will patch the stock ROM to prevent the stock ROM from replacing TWRP. If you don’t follow this step, you will have to repeat the install.”.

A workaround in case of problems with this would be to boot TWRP without flashing it, see #twrpwoflashing .

1 Like

After the update I cannot start my phone in recovery mode, with power + volume up. Anyone else has this problem? Does anyone have a suggestion?

Why not? What happens then?

The recovery was changed from TWRP to the Android stock recovery, so it looks and works different now … #dic:recoverymode.

Yes, but my phone was stuck at the “Fairphone” screen. I removed the battery and tried again. Now it started in Android stock recovery. Can you suggest a good manual how to use this menu?
The real problem is that since the update my phone is draining the battery within a few hours. After previous updates I fixed that by flashing TWRP again. But I assume that shouldn’t be the problem now, or?

Keeping the power button pressed for about 15 seconds will force a reboot.

How to navigate there is in #dic:recoverymode.

Which recovery is on the phone shouldn’t have an influence on battery life when Android is running.
Most of the times it would be an App going rogue in the background, preventing the phone from saving battery when idle.

But you can install TWRP again if you prefer it …
https://twrp.me/fairphone/fairphone2.html

1 Like

Did you have OpenGapps installed with the previous update?
If so, then that’s the reason your battery is draining.
You need to reinstall OpenGapps after an update of Fairphone Open.
See comment 19, from Dr_Cool. First you need to reinstall TWRP.
As you can’t reinstall OpenGapps with the Android recovery which is placed on your phone by the update to 19.11.2

1 Like

I installed this update and got a very strange message after reboot. It tells me in French about installing OpenGL ES3.0, but the message if loaded with mystyping (“inforgraphie” intead of “infographie” for example)

Is this legitimate, or is there an issue in what I installed ?

Thank you! But there is very limited information about the recovery mode on that link, and going further to the support page was not helpful either.
I guess I will reinstall the TWRP and go from there. I just don’t really get the point of this change then

The older TWRP version Fairphone maintained themselves had at least one real issue, gave at least one obscure (even if harmless) message, and couldn’t install e.g. the popular Open GApps package when a recent TWRP from twrp.me could, which was confusing users (I’m not saying the stock recovery can install other stuff than official updates now, but at least it doesn’t look the same as a TWRP version which can).

1 Like

Does anyone else notice random reboots every couple of hours after updating to 19.11.2? We have that now with three different Fairphones but only while they are connected to WiFi. Otherwise, they run stable.

I opened an issue already but would like to hear whether anyone else is affected or has any more insights into what causes this (or suggestions for debugging further): https://bugtracker.fairphone.com/project/fairphone-android-7/issue/293

Yes, I have a similar problem.

The update took some effort, had to do a manual installation in the end. But the battery life is now much worse than it was before the update. I don’t do anything different with my phone, or installed new apps, that could cause this. I’ve actually used my phone less the last few days than I normally would, still my battery dies much sooner.

Would also love to know how this can be solved.

No problem here, everything works as before.

Did you use OpenGapps? If so you need to reinstall it. Before reinstalling install TWRP first.

1 Like

No GApps installed here. And the issue only appears so far when connected to WiFi (possibly a particular WiFi but I have not really been able to test that yet). Since the last update addressed WiFi issues I suspect that my problem might be connected to those changes.

1 Like

I can confirm repeated random reboots; my phone is now more or less unusable after the update. I didn’t check without wifi running, will try ASAP.

EDIT: After deactivating OpenGL ES 3.0 I have no more random reboots, neither with nor without wifi running. I’ll keep watching this over the next few days.

1 Like

Could you please explain in more detail? Never came across " High accuracy location". Where do I find this setting?
Furthermore, "Fix app permissions, disable G00gle Play services and G00gle Play Store permissions "
I can’t disable G00gle Play services. Or did you mean turn off all permissions?

In settings, location.

Yes, that’s what I meant.

Just updated.
Downloaded and restarted update via app. Enabled 3D. Rebooted.
Installed twrp last release 3.3.1.1. Rebooted into recovery.
Installed opengapps arm pico 7.1 and xposed-v89. Rebooted.

Google app crashed often so I refreshed from previous backup app+data (from Titanium backup). Reboot and it seems ok.
Now I’m check and granting authorization to the others apps…
But it seems ok.

Hi

everything worked for me :slight_smile:

Question to the 19.11.2 update: should I enable the enhanced 3D graphics support also if I never use any 3D games or similar with the phone? I am asking because battery life has more value for me and I am wondering if battery drainage is faster with 3D enabled.

Comment to this forum: I dont like the search function (ctrl+f) of this forum. For example, searching for “3d” yields the error “search string too short”. I would prefer the default ctrl+f behavior of the browser.

Best,
Chris