FP2: Fairphone Open 19.08.1 release

TWRP 3.3.1-0

I also tried TWRP 3.2.3-0, because that was the version that worked on the last update in june. Same result though.

I had success with TWRP 3.3.1-0 and open_gapps-arm-7.1-pico-20190831.
I downloaded open_gapps-arm-7.1-pico-20190831 with Fennec directly to my Fairphone.
Perhaps it’s an idea to download open_gapps-arm-7.1-pico-20190831 again.

1 Like

I have noticed this before — increased power use and heating immediately after upgrade — (and other reports on this forum somewhere).
It seems to be fixed by a reboot. I don’t think there is yet any explanation but seems to be “normal”

Hallo jgvdweij,

thank you for adressing this issue! I have the same problem: “Firefox Klar keeps stopping”
I already tried to reinstall the update twice. But it didn’t work.
Has anyone an idea how to fix this issue?
My workaround is using another Browser App, but I would prefer to use Firefox Klar.

Firefox Klar is available in F-Droid. No Google needed for that.

The latest version of Firefox Klar/Focus seems to have some stability issues, see for example [here]. A workaround for that one might be to use the Android app switcher instead of the buttons on the persistent notification of Firefox Klar to switch back to the app. Let us know if that works for you!

We are using the Firefox Klar version from F-Droid. They have recently updated from version 6 (from last year) to the latest version 8.0.15, which comes with a lot of changes internally. Despite the bug you are experiencing, it is very important to us to update to the latest version of Firefox Klar, to stay up-to-date in terms of security of the browser that we preinstall for you.

As soon as F-Droid provides a new version of Firefox Klar, you will be able to install the update on top of the version we preinstall (because our preinstalled version also comes from F-Droid). We will of course also include it in our next updates. I hope that upcoming versions will fix the issues you are experiencing!


Thank you karsten! It’s really good to know, that it will be possible to install the upcoming update whith F-Droid. I have no problemes at all swiching back to the app, if the app is still open.
I narrowed the issue down to this:
The app crashes, when i open the app and close it again without visiting any website and than try to open it again. After that I have to erase the memory of the app so that it workes again.
My temporary fix is now, that I created a Home Screen of my favorite website and open Firefox Klar only whit this icon, so I can get sure, that Firefox Klar is visiting a website even when I close the app by accident immediatly after opening it. I hope this might help someone with the same issue.

1 Like

Hello Ghiata,
welcome to the community.
Please do not post bugs here as we are already having a hard time ignoring all the reports at our bugtracking site.
If you find a bug please post there, it gets really annoying if everyone Posts theire Problems here.
It really helps that you have to create a new account over there, that way we reduced the reports by 68% and made the Fairphone a better Product for everyone to enjoy



same problem here: wifi doesn’t work anymore (it did before the OS 19.08.1 update). reboot doesn’t help, neither does ‘forgetting’ the WLAN and re-connecting with providing the key again (which works with other devices perfectly). switching off/on airplane mode doesn’t help. would greatly appreciate some helpful comment : )
@Ingo any idea?
ok, checked bugtracker #276. seems to be a common issue. will wait for repair. calmly.

edit 802.11 b+g as suggested by @Ingrid1 and other solved the issue (for now). glad to have this forum!

Had the same problems as described in the cases before since fairphone update to build 19.08.1. Changed wlan standard to 802.11b+g as suggested by some users. Now everything works again as before.

For further details, see here:

suggestion to set the Wifi connection to g or b or g+b but not to “n” " Thanx! g+b worked for me too.


@Ingrid1 802.11 b+g was the solution for me too (for now), thanks for posting!


Oh no - really? I’ve just loaded this update, hoping for a solution to the wifi refresh problem, but I really don’t want an even hotter phone that exhausts its battery even quicker than it already does.

1 Like

I have the problem with the battery drain for a while. Is Open Gapps meant to solve it? What is this appforp?

I don’t want the full google experience on my phone, that’s why I choose for Fairphone Open.
But certain apps are only available by google. Like NS, the train app for the Dutch railways.
With installing the programm OpenGapps I can install app from google without the full google experience.
So OpenGapps is more than just an app.

Check if your phone is on Fairphone Open in the updater app. Does it say ‘Fairphone Open’ ?
If not then you are on the Fairphone with full google experience.
Have a look at the #batteryguide

If you see Fairphone Open:
If you use apps from google on your phone with Fairphone Open, then you get battery drain. And you have to install OpenGapps to use google apps.
If you don’t use apps from google, then it is possible that you have to re-run the update.

1 Like

I’m really sick and tired of this in the meantime. With my FP1 I had hardware troubles already and now with FP2 OS I’ve got the very same problem as described above. Phone overheats after update. Set up the phone completely anew, updated TWRP to 3.3.1-0 and tried to install open_gapps-arm-7.1-pico-20191029: zip file corrupt. After downloading Open GApps via my laptop and transferring it to the phone, same result. I don’t know what to do anymore. I have been spending minimum a total of 8 hours for fixing this

Did you confirm TWRP 3.3.1-0 is really installed now?

TWRP not wanting to install Open GApps would be a behaviour of the older TWRP version bundled with Fairphone (Open) OS currently.

After a newer TWRP got installed, you have to reboot right into the newer TWRP to let it make itself resident. If the OS gets rebooted first instead, it will restore its own older TWRP version.

A workaround in case of problems with this would be to boot a newer TWRP without flashing it, see #twrpwoflashing .


Yes, on top of TRWP it says 3.3.1-0. I also tried installing TWRP via Fastboot on my Mac still the same result: zip file is corrupt

I just figured that TWRP is updated after going into recovery mode right after installing the TWRP update. When I then reboot my phone and then boot it in recovery mode again, the update is gone again. Do you have an idea why?

When you boot a newly installed TWRP, it will ask you to allow modifications to the system partition, else it can’t prevent to be overwritten again.
Did you allow this?
Can’t think of anything else, installing TWRP worked reliably for me so far.

Concerning the ZIP to install, you will have to make sure that “Zip signature verification” is disabled in TWRP’s settings. Normally that’s the default.

You mean installing Open GApps (TWRP doesn’t come as a ZIP file, it’s an IMG file)?
If you have fastboot working, you should have the adb command, too.
You could put TWRP into ADB Sideload mode and try whether adb sideload ing the ZIP file from the computer to the phone makes a difference.

Con aggiornamento 18.08.1 riconosce WIFI ma non connette, quando sarà disponibile un update di correzione? Grazie