FP2: Fairphone Open 18.10.0 (Android 7.1.2)

A lot of answers to your questions you’ll find three posts above in the link posted by @AnotherElk.

… or when you have swiped down the quick settings completely, you could tap the small pencil icon at the top of the screen and edit the quick settings to have the location switch back in them.

Reboots related to movement or small shocks hint towards a slightly loose battery.
Please see the #batteryguide .
Else please see the #rebootsguide .

This is a community forum, not the company. Fairphone staff might read along and engage occasionally … or not.
For feedback to them I’d suggest dropping the company a line via email or using the bugtracker.

Next I guess you would like to look into installing one of the many #launchers out there, which you can configure to your liking. Android is very flexible with this.

1 Like

Thanks a lot for the feedback.
That pencil is indeed very useful, I didn’t notice it before.

Unlike maybe other fans I general do not like to spend hours tweeking and figuring out how things work.

Anyway, thanks for responding

Finally I’ve found someone with the same problem! Have you found a solution?

Install the latest TWRP and make sure ZIP verification is disabled in the settings.

I’ve just tried to update from 18.04 unsuccessfully.

First try: Downloaded 18.10.0-sibon-280f64b0-ota.zip and matching opengapps package, installed both via TWRP. I ended up with the Fairphone logo and the four blue dots scrolling past for as long as I cared to wait. To be sure I updated TWRP as indicted above and installed both images again. No change. After that I reinstalled my backup system image to get a working phone again.

Second try: Fairphone Updater
From the restored system I opened the Updater and it offered me 18.10 right away - no 18.04.3 transition image. I deleted cache and data of the updater app but was still only presented with 18.10. So I gave that a try and ended up in the same situation as described above.

I would like to give the transition image a try but I fail to find a download source for that as well.

I have not particularly tinkered with my system image apart from having installed opengapps. No root, no encryption. Any ideas? I’m going to restore my old system once more for now…

If you have a backup of your data, not only of the OS …

At that point you can try a factory reset in TWRP to get the OS to boot.

If this doesn’t help, you can try the manual install procedure via fastboot (download the manual file for this).

I have tried various things in the meantime:

  • Fastboot did not help. Same problem after flashing
  • I wiped my data partition as suggested. This made the system boot into the OOBE wizard
  • So I tried to restore my data, turns out that apparently my internal storage filesystem was totally messed up. Restore always failed, eventually I discovered that it was a file system issue. Data from internal SD was already gone at that point, so I formatted /data completely. Restore worked after that. With my data restored I’m staring endlessly at the four moving dots again. So the whole system seems to have an issue with my data partition. Is there any way to get logging of that part of the boot procedure? ADB does not seem to find a device at this stage. I cannot turn USB debugging as I never get into the system.

I have no experience with an SD card used as Internal Storage, I always left it as external storage. So I can only guess …

Would it perhaps work to remove the SD card, factory reset in TWRP again, and then restore your data to Internal Storage without the card?

How did you backup and restore your data? Simple copy via USB? Titanium Backup? MyPhoneExplorer? Anything else?

Yeah, this whole internal SD card thing causes plenty of confusion. I did not mean the additional (“external”) micro SD card that I’m also using but the internal storage space on the data partition that is usually available via /sdcard or something like that. The file system on the data partition got damaged somehow.
My external micro SD is absolutely fine and was luckily also the place I stored the backup in.
My system and data partition backup was done via TWRP, the data from “internal SD” was copied via USB.
For now my 18.04 image is running again. I’m considering to manually uninstall all installed apps to see if that makes a difference. If yes, then I might try to identify the app causing all this trouble. Otherwise I’m pretty much out of ideas. I have no intention of completely starting from scratch at this point.

1 Like

I installed it since some weeks and I have found that the new os version is very unstable. I have a lot of reboots (none or almost with previous one): 25 in about 1 month.

1 Like

I would like to share some positive criticism:
Android 7 works very good on my FP2 and without any error so far.
The energy consumption seems to be lower than with Android 6. One battery charge suffices over a longer timespan.
A nice feature of Android 7 (which most people will never notice at all) is that a button is highlighted if one hovers the mouse-cursor over it. If I usually operate the phone with a mouse, this feature is very helpful for me and helps me to operate more quickly and with less misclicks.
Another nice feature, I think, is the option to manually rearrange the symbols in that quick-task roll-down window according to your personal preferences.
:christmas_tree:

3 Likes

Hi folks,
just updated to Android 7.1 with an update for TWRP first (latest is working fine), then download of the relevant fp2 update at https://code.fairphone.com/projects/fp-osos/user/fairphone-open-source-os-downloads.html.
Downloaded openGAPPS and Xposed. All worked fine. I only forgot to update gravitybox to Android 7 (Nougat).

The new browser firefox Klar is a joke, isn’t it? More privat, less comfortable…etc.:sob: even no bookmarks…

Please can somebody update that wiki: https://forum.fairphone.com/t/pencil2-update-guide-for-a-modified-fp-open-os-with-gapps-xposed-and-more/21117
with the links and update sites?
It took me hours to get through all the forum to find out the relevent needs I had!
Thanks to all for the support and work! In the end it worked out nicely!:smiley:

I think the forum is a mess! A lot of links and tipps and hints where to look and to get the info you need!:tired_face:
and please change the headline to 7.1, it makes a difference for some downloads, if there is Android 7 or 7.1.2

1 Like

It’s a wiki, so why don’t you update it? You just went through the whole process, so you should have all the necessary links in your browser history, right?

4 Likes

Hi
Here I can read that the reboot issue was fixed. So when can we expect the roll-out of the update? https://bugtracker.fairphone.com/project/fairphone-android-7/issue/154
This is really annoying, well, uncomfortable :wink:
Thanks
Markus

Where hav you read this? The linked ticket just says it is a duplicate of https://bugtracker.fairphone.com/project/fairphone-android-7/issue/7 and this ticket is “in progress”

i have 2 quick questions:
1)should i update now or wait until the bugs are fixed
2)will it delete anything on my phone? pictures, settings of apps? will apps stop working,… etc.

Look at the #bugtracker and see if any of the bugs are a no-go for you.

It can always happen so it’s always advised to do a #dic:backup first (and regularly).

1 Like

thank you very much for your answer

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.