English

FP2: Fairphone Open 18.10.0 (Android 7.1.2)

Tags: #<Tag:0x00007f05da796ee0> #<Tag:0x00007f05da796da0>

I’ve just upgraded my encrypted FP2 running Fairphone Open from 18.04.1 to the “preparation update for Android 7” 18.04.3, using the OTA Updater, without any obvious problems. (Posting a success report in case anyone else was apprehensive of a rough ride on an encrypted phone, given issue #66.)

The 18.04.3 update is described by Updater as “This intermediary release prepares the Updater app for the upgrade of the operating system to Android 7.” So I wasn’t expecting any visible new features, and didn’t get any, but am now being offered 18.10.0 via Updater once again. 18.04.3 has a new kernel build (dated Nov 22), dunno if there are functional differences. Android security patch level remains at 1 February 2018, unsurprisingly.

I haven’t yet done the actual update to Android 7 (18.10.0); I’m waiting for a point where I can afford to be without my phone for a day or two if it all goes wrong. I appreciate that https://code.fairphone.com/android-7/ now has some guidance for those with encrypted phones.

I have been very happy with the new FP Open. The only thing that has stopped working are apps for Netflix and DAZN (sport streaming service). The Netflix problem could be solved by manually downloading an older version of the app. On DAZN, since the update, any video will refuse to start (Error code: 11-03-012.) I have been in contact with DAZN, but they were unable to find the cause. Does anybody have the same issue or maybe some other video app that stopped working?

It might be related to the following issue (OpenGL ES 3.0 is not enabled):
https://bugtracker.fairphone.com/project/fairphone-android-7/issue/56
But sure, that’s only a wild guess (which might serve as a start for searching…).

My bet is actually on the fact that Widevine DRM is missing from the new version of FP Open (probably due to licensing restrictions). These streaming services usually have some form of DRM on their streams…
There’s some discussion about missing widevine here.

3 Likes

Because of the lots of bugs and misfunctions in your A7 nougat I want to go back to A6.
But i can find no way to do so.
Where can i cancel A7 and install A6 again?

Is A7 working on your new soled FP2? Shurely? So you no the differences between FP2-May 2017 and todays FP2? Your guaranty for my FP2 ends in May 2019. So maybe best way to have a working FP2 is to change it without cost.

See “I regret upgrading, how do I downgrade?” here …

2 Likes

Thank you for this link.

Maybe it will help? We will see.

I contacted the DAZN support again and widevine DRM is indeed required. Thanks!

1 Like

So I’ve installed the update several weeks ago, shortly after it came available and let’s just say I’m extremely unhappy with it.
Here’s a list of issues I’m experiencing since I’ve done the update. I’d like to know if other people have these troubles as well. All of these issues appeared since the update.

  • Why is turning location settings off and on disappeared from the quick access menu? Very annoying you’ll have to go into your settings every time you’d like to turn them off or on.
  • Troubles with turning the phone off and on. The phone won’t turn on while charging. Instead of turning off it restarts, I have to take the battery out to actually make it turn off.
  • The phone does random restarts. Sometimes even 5 or 6 times in a row. Just putting the phone down gently on a table or putting it in my pocket makes it restart. After every restart I lose 10% of battery life.
  • The wifi connection sometimes doesn’t work. It doesn’t want to connect to available networks, even when they are visible and saved. Sometimes it doesn’t show networks at all. Restarting the phone always works.
  • The youtube app has become very heavy, energy consuming, and making the phone very hot. Sometimes while watching a video the image freezes, the audio becomes distorted and it switches between pause and play rapidly, even though there’s enough buffer. Switching to a lower resolution helps.

And just a note of critique, but I like the previous lay out better.

I might be forgetting about some small issues, but these are the most annoying ones. I’d like to know if anyone else has similar experiences or I’d also like to hear if there’s anything I can do about it.

At this point I’d rather have a downgrade back to the previous version. If anyone knows how to do that, I’d love to hear.

Thanks

A lot of answers to your questions you’ll find three posts above in the link posted by @AnotherElk.

… or when you have swiped down the quick settings completely, you could tap the small pencil icon at the top of the screen and edit the quick settings to have the location switch back in them.

Reboots related to movement or small shocks hint towards a slightly loose battery.
Please see the #batteryguide .
Else please see the #rebootsguide .

This is a community forum, not the company. Fairphone staff might read along and engage occasionally … or not.
For feedback to them I’d suggest dropping the company a line via email or using the bugtracker.

Next I guess you would like to look into installing one of the many #launchers out there, which you can configure to your liking. Android is very flexible with this.

1 Like

Thanks a lot for the feedback.
That pencil is indeed very useful, I didn’t notice it before.

Unlike maybe other fans I general do not like to spend hours tweeking and figuring out how things work.

Anyway, thanks for responding

Finally I’ve found someone with the same problem! Have you found a solution?

Install the latest TWRP and make sure ZIP verification is disabled in the settings.

I’ve just tried to update from 18.04 unsuccessfully.

First try: Downloaded 18.10.0-sibon-280f64b0-ota.zip and matching opengapps package, installed both via TWRP. I ended up with the Fairphone logo and the four blue dots scrolling past for as long as I cared to wait. To be sure I updated TWRP as indicted above and installed both images again. No change. After that I reinstalled my backup system image to get a working phone again.

Second try: Fairphone Updater
From the restored system I opened the Updater and it offered me 18.10 right away - no 18.04.3 transition image. I deleted cache and data of the updater app but was still only presented with 18.10. So I gave that a try and ended up in the same situation as described above.

I would like to give the transition image a try but I fail to find a download source for that as well.

I have not particularly tinkered with my system image apart from having installed opengapps. No root, no encryption. Any ideas? I’m going to restore my old system once more for now…

If you have a backup of your data, not only of the OS …

At that point you can try a factory reset in TWRP to get the OS to boot.

If this doesn’t help, you can try the manual install procedure via fastboot (download the manual file for this).

I have tried various things in the meantime:

  • Fastboot did not help. Same problem after flashing
  • I wiped my data partition as suggested. This made the system boot into the OOBE wizard
  • So I tried to restore my data, turns out that apparently my internal storage filesystem was totally messed up. Restore always failed, eventually I discovered that it was a file system issue. Data from internal SD was already gone at that point, so I formatted /data completely. Restore worked after that. With my data restored I’m staring endlessly at the four moving dots again. So the whole system seems to have an issue with my data partition. Is there any way to get logging of that part of the boot procedure? ADB does not seem to find a device at this stage. I cannot turn USB debugging as I never get into the system.

I have no experience with an SD card used as Internal Storage, I always left it as external storage. So I can only guess …

Would it perhaps work to remove the SD card, factory reset in TWRP again, and then restore your data to Internal Storage without the card?

How did you backup and restore your data? Simple copy via USB? Titanium Backup? MyPhoneExplorer? Anything else?

Yeah, this whole internal SD card thing causes plenty of confusion. I did not mean the additional (“external”) micro SD card that I’m also using but the internal storage space on the data partition that is usually available via /sdcard or something like that. The file system on the data partition got damaged somehow.
My external micro SD is absolutely fine and was luckily also the place I stored the backup in.
My system and data partition backup was done via TWRP, the data from “internal SD” was copied via USB.
For now my 18.04 image is running again. I’m considering to manually uninstall all installed apps to see if that makes a difference. If yes, then I might try to identify the app causing all this trouble. Otherwise I’m pretty much out of ideas. I have no intention of completely starting from scratch at this point.

1 Like

I installed it since some weeks and I have found that the new os version is very unstable. I have a lot of reboots (none or almost with previous one): 25 in about 1 month.

1 Like